Microsoft Office Tutorials and References
In Depth Information
3.23.2 Eine Artikelnummer automatisch auffüllen lassen
Der Aufbau der Funktion lautet:
=WIEDERHOLEN(A7;B7)
6. Kopieren Sie die Funktion nach unten.
Bild 3.49: Einen Zellinhalt beliebig oft wiederholen mit der Funktion WIEDERHOLEN
In der vorherigen Abbildung wird der Text in der Zelle A7 zweimal wiederholt. In der
Zelle A8 steht hinter dem Wort »Piep« noch ein Leerzeichen. Nach viermaligem
Wiederholen sehen Sie das Ergebnis in Zelle C8.
3.23.2 Eine Artikelnummer automatisch auffüllen lassen
Sie haben Artikelnummern, die nicht gleich lang sind. Sie möchten, dass alle Artikel-
nummern aus sechs Stellen bestehen. Excel soll die, die aus weniger als sechs Zeichen
bestehen, automatisch mit Nullen auffüllen. Das folgende Beispiel finden Sie auf dem
Register Wiederholen_2 . Der Aufbau der Funktion sieht folgendermaßen aus:
=WENN(LÄNGE(A2)<>6;A2&WIEDERHOLEN(0;6-LÄNGE(A2));A2)
Der erste Teil
=WENN (LÄNGE(A2)<>6;
prüft, ob die Länge ungleich 6 ist. Sollte dies zutreffen, wird der Dann_Wert ausgeführt:
A2&WIEDERHOLEN(0;6-LÄNGE(A2));
Der Inhalt der Zelle wird mit 0 aufgefüllt, und zwar so oft, wie Zeichen fehlen.
Der Sonst_Wert nimmt nur den Inhalt der Zelle
A2)
Bild 3.50: Eine Artikelnummer mit Nullen auffüllen
Search JabSto ::




Custom Search