Microsoft Office Tutorials and References
In Depth Information
6.10.2 Die Fehlermeldung #NV unterdrücken
5. Kopieren Sie die Funktion nach unten.
Bild 6.28: Ein paar
Beispiele für die
Funktion ISTNV
In der folgenden Abbildung erkennen Sie, dass nur in der Zelle A7 die Fehlermeldung
# NV steht, daher ist das Ergebnis Wahr .
6.10.2 Die Fehlermeldung #NV unterdrücken
Die folgende Abbildung zeigt die Situation, dass nach Eingabe einer Personalnummer,
die nicht in der Liste existiert, die Fehlermeldung # NV angezeigt wird. Dies können Sie
mit einer Kombination der Funktionen WENN und ISTNV abfangen.
Bild 6.29: Wenn es die
Personalnummer nicht gibt, erscheint
die Fehlermeldung #NV.
Um diese Meldung zu unterdrücken, fangen Sie sie mit einer WENN-Funktion ab.
Wenn die SVERWEIS-Funktion den Fehler #NV liefert, dann schreibe den Text Bitte
gültige P-Nummern eingeben , ansonsten zeige den Nachnamen an.
=WENN(ISTNV(SVERWEIS(F7;$A$1:$D$8;3;FALSCH));"Bitte gültige P-Nummern
eingeben";SVERWEIS(F7;$A$1:$D$8;3;FALSCH))
Im ersten Teil der WENN-Funktion
WENN(ISTNV(SVERWEIS(F7;$A$1:$D$8;3;FALSCH));
wird geprüft, ob die Funktion SVERWEIS die Fehlermeldung #NV liefert.
Wenn dies zutrifft, wird der folgende Text angezeigt:
"Bitte gültige P-Nummern eingeben";
Ansonsten wird die SVERWEIS-Funktion ausgeführt.
SVERWEIS(F7;$A$1:$D$8;3;FALSCH))
Search JabSto ::




Custom Search