Microsoft Office Tutorials and References
In Depth Information
6.11.3 Als Text formatierte Zahlen erkennen
Wenn in der Zelle C6 ein Text steht, dann schreibe eine 0, ansonsten teile B6 durch C6.
Der Aufbau der Funktion:
=WENN(ISTTEXT(C6);0;B6/C6)
Im ersten Teil der WENN-Funktion brauchen Sie keinen Vergleich mehr, da die Funk-
tion ISTTEXT ja nur den Wert Wahr oder Falsch liefert. Also je nach Ergebnis nimmt
die WENN-Funktion den Wahr -Teil, die 0 oder den Falsch -Teil B6/C6.
Bild 6.33: Die Lösung:
Es wird nur dann
dividiert, wenn der
Inhalt der Spalte C
kein Text ist.
6.11.3 Als Text formatierte Zahlen erkennen
Sie haben nach einem Import das Gefühl, dass nicht alle Zahlen, die Sie in den Zellen
sehen, von Excel auch als Zahlen interpretiert werden.
Die folgende Abbildung zeigt das Dilemma:
Bild 6.34: In der Beispieltabelle
ist zu erkennen, wo Texte stehen.
In der Spalte A sind in den Zellen A14 und A18 zwar vordergründig Zahlen zu erken-
nen, nur interpretiert Excel diese als Text. Sie erkennen dies an der Kontrollsumme in
A23 bzw. D23.
Search JabSto ::




Custom Search