Microsoft Office Tutorials and References
In Depth Information
2.6.1 Ein einfaches Beispiel zur Matrixfunktion
Falls es sich nicht um die gesuchten Begriffe handelt, weisen wir in der WENN-Funktion
das Ergebnis 0 aus.
Um die Formel auf den gesuchten Zeilenbereich zu erweitern, werden die Zellbezüge
von einer einzelnen Zelle auf einen Zellbereich geändert:
=WENN(A3:A16="D";WENN(B3:16="GUGEL";C3:C16;0))
Diese Formel erweitert den Zeilenbereich gleichmäßig auf die Zeilen 3 bis 16.
Auf diese Funktion wird anschließend die SUMME-Funktion angewendet, um alle
gefundenen Werte zu addieren:
=SUMME(WENN(A3:A16="D";WENN(B3:16="GUGEL";C3:C16;0)))
Wenn Sie diese Funktion mit der (Eingabe) -Taste bestätigen, wird als Ergebnis 0 ausge-
geben, da Excel die Auswertung der WENN-Funktion auf Zellbereiche nicht versteht.
Als Matrixfunktion würde Excel die Funktion jedoch korrekt für alle angegebenen
Zellen im Zellbereich berechnen.
Das Wichtigste kommt beim Abschluss der Formeleingabe.
Drücken Sie statt der normalen (Eingabe) -Taste die folgende Tastenkombination:
(Strg) + (Umschalt) + (Eingabe)
Bild 2.34: Das Ergebnis der Matrixfunktion
Nach Eingabe dieser Tastenkombination werden um die Funktion geschweifte Klam-
mern gesetzt.
{=SUMME(WENN(A3:A16="D";WENN(B3:16="GUGEL";C3:C16;0)))}
Dann wird das Ergebnis für den Zellbereich (Matrixbereich) ausgerechnet.
Die Berechnung können Sie analog mit der normalen Excel-Funktion SUMMEWENNS
durchführen. Die Formel lautet dann:
=SUMMEWENNS(C3:16; A3:A16; E3; B3:16; F3)
Search JabSto ::




Custom Search