Microsoft Office Tutorials and References
In Depth Information
3.12.1 Wie viele Zeichen enthält die Zelle?
3.12.1 Wie viele Zeichen enthält die Zelle?
In diesem Beispiel soll Excel zählen, wie viele Zeichen eine Zelle enthält.
1. Öffnen Sie die Datei LÄNGE.XLSX und aktivieren Sie das Register Länge_1 . Setzen
Sie den Cursor in die Zelle C7 und starten Sie die Funktion LÄNGE über den Funk-
tions-Assistenten.
2. Geben Sie ins Feld Text die Zelladresse ein, deren Zeichen Sie zählen möchten. In
diesem Beispiel ist es A7.
3. Bestätigen Sie mit OK .
Der Funktionsaufbau:
=LÄNGE(A7)
4. Kopieren Sie die Funktion nach unten.
Bild 3.22: Die Funktion LÄNGE
zählt die Anzahl der Zeichen in
der Zelle.
Das Ergebnis zeigt jetzt die genaue Anzahl der Zeichen inklusive Leerzeichen in einer
Zelle.
3.12.2 Artikelnummern automatisch auffüllen
Müssen Ihre Artikelnummern beispielsweise immer sechsstellig sein und möchten Sie
sie nun automatisch mit Nullen auffüllen lassen, wenn sie vierstellig sind, wäre ein
gewünschtes Ergebnis von 1234 nach 123400. Das folgende Beispiel finden Sie auf dem
Register Länge_2. Mit einer WENN-Funktion prüfen Sie, ob die Artikelnummer
vierstellig ist. Wenn ja, dann werden zwei Nullen an die Artikelnummer angehängt.
Andernfalls wird die Artikelnummer angezeigt.
=WENN(LÄNGE(A2)=4;A2&"00";A2)
Der erste Teil der WENN-Funktion prüft mit der Funktion LÄNGE, ob die Artikel-
nummer vierstellig ist:
WENN(LÄNGE(A2)=4;
Search JabSto ::




Custom Search