Microsoft Office Tutorials and References
In Depth Information
„=A1>A2“. Das Ergebnis einer solchen Prü-
fung ist entweder WAHR oder FALSCH. Ermit-
telt Excel einen solchen Wahrheitswert, dann
ist das Ergebnis immer 1 oder 0. Sie wissen
ja, dass 1 genau einem Tag oder 24 Stunden
entspricht. Also führt auch die folgende For-
mel zum gewünschten Ergebnis:
Frei nach BOOLE: Auch diese Funktion lie-
fert ein korrektes Ergebnis.
=(A1>B1)+B1-A1
Die Funktion kurz erläutert: Ist wie in un-
serem Beispiel die Startzeit größer als die En-
dezeit, wird einfach „hintenrum“ gerechnet:
Der kleinere Wert wird vom größeren abgezo-
gen, was in unserem Beispiel 16:00 ergeben
würde. Dieser Wert wird dann von 1 (was ja
24:00 entspricht) abgezogen – voilà, schon
haben wir die erwarteten 8 Stunden als Er-
gebnis der Berechnung!
Hier ist A1 wirklich größer als B1, die Wahr-
heitsprüfung liefert also WAHR und damit den
Wert 1, zu dem dann der kleinere Wert (also
24:00 plus 5:00) addiert wird. Vom Ergebnis
wird dann der größere Wert wieder abge-
zogen – das Ergebnis stimmt damit wieder.
Vorzeichen ausgeben
Auch die folgende WENN-Abfrage
würde das korrekte Ergebnis lie-
fern: =WENN((B1-A1)>0;B1-
A1;TEXT(ABS (1+B1-A1);
tipp
Eine zweite Möglichkeit besteht in ei-
ner so genannten Wahrheitsprüfung (auch
boolescher Vergleich genannt) in der Art
Search JabSto ::




Custom Search