Microsoft Office Tutorials and References
In Depth Information
Abbildung 4.2 Beispiel für Rundungsdifferenzen
In der Spalte D sind die Ergebnisse der benachbarten Spalte C mit der Funktion RUNDEN()
bearbeitet worden. In F6 ist das nicht gerundete Gesamtergebnis mit 17 multipliziert, in
F7 das gerundete Gesamtergebnis. Die Differenz ist deutlich.
Division durch null abfangen
Bei der Division ist die Anzahl der Dezimalstellen, die der Quotient erhält, ganz unter-
schiedlich. Hier kommt zu dem bei der Multiplikation angesprochenen Rundungspro-
blem ein weiteres hinzu, das unbedingt beachtet werden muss: Die Division durch null
ist nicht erlaubt. Solange der Divisor direkt eingegeben wird, lässt sich dieser Fehler re-
lativ leicht vermeiden. Was aber, wenn der Divisor eine Zelladresse oder eine Funktion
ist, deren Ergebnis unvorhersehbar ist, wenn also der Divisor eine Variable, eine Unbe-
kannte ist. Für diesen Fall muss Vorsorge getroffen werden.
Der Fall, dass ein Divisor mit dem Wert 0 verwendet wird, sollte unterbunden werden.
Das ist möglich mit der Funktion WENN() . Dem Programm kann damit erklärt werden, was
anstelle einer Division zu geschehen hat, wenn der Divisor tatsächlich den Wert 0 an-
nehmen sollte. Das kann etwa so aussehen:
=WENN(B3<>0;RUNDEN(A3/B3;2);"")
Wenn der Wert der Zelle B3 ungleich 0 ist, wird die Division A3/B3 durchgeführt; ist B3
aber tatsächlich gleich 0, findet die Division erst gar nicht statt, die Zelle bleibt leer.
Stattdessen könnte auch ein entsprechender Hinweis ausgegeben werden.
Search JabSto ::




Custom Search