Microsoft Office Tutorials and References
In Depth Information
Einfügen
Beim Einfügen müssen zwei Fälle unterschieden werden. Im ersten Fall wird eine Zelle,
auf die sich eine Formel bezieht, durch das Einfügen von Zellen, Spalten oder Zeilen ver-
schoben. Wird beispielsweise zwischen Spalte B und Spalte C eine neue Spalte einge-
fügt, wird die Formel =B5-C5 verändert in =B5-D5 . Das gilt auch bei absoluten Bezügen.
Der zweite Fall ist, dass durch das Einfügen von Zellen, Spalten oder Zeilen ein Bereichs-
bezug verändert wird. Das gilt auch für benannte Bereiche. Angenommen, in Zelle B10
steht =SUMME(B5:B9) . Sie fügen bei Zeile 7 zwei Zeilen ein. Die Formel wird automatisch auf
=SUMME(B5:B11) erweitert. Wird dagegen bei Zeile 5 – also vor dem Bereich – eine Zeile ein-
gefügt, gehört sie nicht zum summierten Bereich, die Formel lautet =SUMME(B6:B12) . Wird
die letzte Zelle des Bereichs markiert und eine Zeile eingefügt, verschiebt Excel die bis-
her letzte Zeile um eine Zeile nach unten. Aus =SUMME(B5:B12) wird =SUMME(B5:B13) .
Der Haken an der Sache ist, dass dadurch die Reihenfolge in dem Bereich möglicher-
weise nicht mehr der entspricht, die Sie haben wollen. Lässt sich das nicht durch eine
Sortierung regeln, ist es besser, die neue Zeile vor der Zeile einzufügen, die die Sum-
menformel enthält, und die Bereichsdefinition in der Formel zu korrigieren. Das oben
Gesagte gilt auch für benannte Bereiche.
Spezialfall Matrix
Bei Matrixformeln gilt die Einschränkung, dass in die Ergebnismatrix keine Zellen ein-
gefügt werden können. Wenn Sie es versuchen, erhalten Sie eine Fehlermeldung. Ist es
notwendig, muss die Matrixformel für den neuen Bereich neu eingegeben werden.
Handelt es sich um eine komplizierte Formel, können Sie einen kleinen Trick anwen-
den. Klicken Sie doppelt auf die erste Formel. Markieren Sie den ganzen Eintrag, und
kopieren Sie ihn in die Zwischenablage. Brechen Sie die Bearbeitung mit [Esc] ab.
Markieren Sie mit [Strg]+[/] die Ergebnismatrix, und löschen Sie diese. Markieren
Sie die neue Ergebnismatrix. Klicken Sie doppelt auf die aktive Zelle, und verwenden
Sie Bearbeiten Einfügen , um die alte Formel einzutragen. Nun müssen in der Regel
die Bereiche für die Argumente bzw. Operanden korrigiert werden. Markieren Sie
diese per Doppelklick, und markieren Sie die neuen Bereiche. Schließen Sie mit
[Strg] + [ª] + [¢] ab.
Löschen
Wird der Inhalt einer Zelle gelöscht, auf die sich eine Formel bezieht, wird die leere
Zelle in der Formel so gewertet, als ob Sie den Wert 0 eingetragen hätten. Zu einem Pro-
Search JabSto ::




Custom Search