Microsoft Office Tutorials and References
In Depth Information
Allerdings gilt die Verzweigung immer nur in Bezug auf das Ergebnis in der Zelle
selbst. Es ist nicht möglich, mit der Funktion WENN() direkt einen neuen Wert in eine
andere Zelle einzutragen. Es ist zwar möglich, etwa in der Zelle B3 zu schreiben:
=WENN(B1>1000; B2=100; B2=200)
Ist B1 tatsächlich größer 1.000, bedeutet diese Formel aber lediglich, dass Excel nun
prüft, ob die Zelle B2 tatsächlich den Wert 100 enthält. Ist dies der Fall, ist das Ergeb-
nis in Zelle B3 der Wert WAHR .
Eine direkte Wertzuweisung an eine Zelle, die dann eventuell auch Werte überschreibt,
die bisher in dieser Zelle eingetragen waren, kann nur über Makrobefehle erreicht wer-
den. Das schließt natürlich nicht aus, dass eine andere Zelle durch einen Adressbezug den
Wert aus der Zelle übernimmt, in der die Funktion WENN() steht. Wenn Sie in die Zelle B3
=WENN(B1>1000; 100; 200)
schreiben und in Zelle B2
=B3
erhalten Sie das Ergebnis, das Sie mit der ersten Formel erreichen wollten. In den fol-
genden Abschnitten soll die Nützlichkeit der Funktion WENN() an einigen Beispielen ver-
deutlicht werden.
16.11.3
Texte automatisch anpassen
In der abgebildeten Tabelle sind Kundenumsätze einer Firma für zwei Jahre eingetra-
gen, in der Spalte B der Umsatz für 2008, in der Spalte C der für 2009. Die Kunden, de-
ren Umsatz gegenüber dem Vorjahr um mehr als 2 % abgesunken ist, sollen in der Spalte
D so markiert werden, dass sie auf einen Blick zu erkennen sind. Die Formel kann in der
Zelle D7 eingetragen und dann die Spalte hinunterkopiert werden. Sie könnte folgen-
dermaßen lauten:
=WENN(C7<(B7*0,98); "deutlicher Umsatzrückgang"; "")
Bei den Kunden, deren Umsatz im Jahr 2009 tatsächlich um mehr als 2 % gesunken ist,
erscheint in der Spalte D der Hinweis: deutlicher Umsatzrückgang . Bei allen anderen
Kunden bleibt die Zelle in der Spalte D als Ergebnis der Formel leer.
Search JabSto ::




Custom Search