Microsoft Office Tutorials and References
In Depth Information
Im Zusammenhang mit Abbildung 3.18:
1. Lesen Sie in Spalte F eine beliebige Personalnummer ein.
2. Markieren Sie den gesamten Bereich H12:K21 . Sie werden deshalb Ihre Formeln gleich auch in
Spalte J eingeben, wo sie nichts zu suchen haben. Das ist jedoch unerheblich. Die pauschale
Markierung macht den Vorgang einfacher, das Zuviel ist im Anschluss schnell beseitigt.
3. Aktive Zelle ist H12 . Geben Sie in der Bearbeitungsleiste als ersten Teil der Formel bis zur
öffnenden Klammer =WENN(ISTLEER($F12);"";SVERWEIS( ein und drücken Sie dann (Strg) + (ª) + (A) ,
um die Syntax der Funktion SVERWEIS einzulesen.
4. Doppelklicken Sie auf das Argument Suchkriterium , um es zu markieren, klicken Sie auf die
Zelle F12 , um diese zum Bezug zu machen, und verwandeln Sie ihn sofort danach mit (F4)
zum spaltenabsoluten, also zu $F12 .
5. Doppelklicken Sie auf das Argument Matrix , um es zu markieren, und drücken Sie (F3) . Wäh-
len Sie im Dialogfeld Namen einfügen den Bereichsnamen rP1.Stammdaten , um diesen zum
Bezug zu machen.
6. Doppelklicken Sie auf das Argument Spaltenindex , um es zu markieren, klicken Sie auf die Zelle
H3 , um diese zum Bezug zu machen, und verwandeln Sie ihn sofort danach mit (F4) zum
zeilenabsoluten, also zu H$3 .
7. Doppelklicken Sie auf das Argument Bereich_Verweis , um es zu markieren, und überschreiben
Sie die Markierung mit dem Wert FALSCH , um Excel anzuweisen, nur auf genaue Übereinstim-
mungen mit den Suchkriterien zu reagieren.
8. Sie haben nun mit dem SVERWEIS -Teil eine WENN -Formel vollendet, es fehlt jetzt noch deren
schließende Klammer (also zwei schließende Klammern am Ende der Formel).
9. Geben Sie die Formel mit (Strg) + (¢) in den gesamten markierten Bereich H12:K21 ein.
10. In Spalte J mit der Überschrift LE werden die Formeln nicht gebraucht. Sie erzeugen hier im
Moment den Fehlerwert #WERT! , weil in Zeile 3 dieser Spalte keine Information für den Spalten-
index der SVERWEIS -Formelteile zu finden ist. Markieren Sie die Zellen J12:J21 und entfernen Sie
deren Inhalte.
11. Testen Sie die Richtigkeit der Formelzugriffe, indem Sie in der Spalte P_Code verschiedene
Personalnummern eingeben und dann überprüfen, ob die richtigen Mitarbeiternamen mit
ihren richtigen Daten geliefert werden. Nur wenn in Spalte P_Code eine Personalnummer zu
sehen ist, dürfen in der gleichen Zeile auch Formelergebnisse erscheinen. Zwischen leeren
Zellen und Zellen, für die keine Suchvorgaben existieren, besteht also optisch kein Unter-
schied. Deshalb sollten Sie hier besonders gut darauf achten, ob Sie die Formel tatsächlich in
alle relevanten Zellen eingegeben haben.
Stellvertretend für alle die Formel in Zelle H12
=WENN(ISTLEER($F12);"";SVERWEIS($F12;rP1.Stammdaten;H$3;FALSCH))
als Anweisung: »Wenn die Zelle F12 leer ist, dann erzeuge leeren Text. Ansonsten führe eine SVER-
WEIS -Formel aus, deren Suchkriterium in Zelle F12 steht, deren Matrix der Bereich rP1.Stammdaten ist,
deren Spaltenindex als Vorgabe in Zelle H3 steht und bei der auf genaue Übereinstimmungen zu
achten ist.«
Search JabSto ::




Custom Search