Microsoft Office Tutorials and References
In Depth Information
Nr.
Zelle
zugehörige Beschriftung
Formel
6
M5
Ta g e / M a x
=VERGLEICH($K5;rB1.Messwerte;0)
7
L5
Datum / Max
=INDEX(rB1.Messtage;$M$5;1)
8
M3
Tage / Tage Gesamt
=$L$6-$L$4
Tabelle 4.1 Mit diesen Formeln werden die Variablen der Informationstexte vorbereitet (Fortsetzung)
Die Reihenfolge der Auflistung in Tabelle 4.1 folgt mehr der Logik der Berechnungen und deren
Ergebnisverwendung als dem Zeilen-Spalten-Raster. Unter Nutzung der Zeilennummerierung
dieser Tabelle einige Anmerkungen zu den Formeln:
1.
In der Hilfsspalte I stehen nur die laufenden Nummern jener Zeilen, in denen die Daten ermit-
telt werden. Deswegen ist das die gesamte Spalte abgreifende Zeilenargument MIN(I:I) sehr gut ver-
wendbar, weil es zuverlässig die Zeile mit der Nummer 1 identifiziert, egal wo sie sich befindet.
2.
Auf einfache Weise das Maximum der Messwerte zu ermitteln ist hier ausreichend, weil es für
die Weiterverarbeitung zunächst keine Rolle spielt (später hingegen ja, vgl. bei Ziffer 6), wo
sich dieser Wert befindet.
3.
Wie unter 1. Der Vorteil hier: Solange die Zeilennummerierung mit der Anzahl der Formeln
enthaltenden Zellen synchronisiert ist (also auch nicht mehr oder weniger Zeilen hoch),
ermittelt diese Formel immer den Wert des letzten Eintrags der Spalte, ohne dass zu prüfen
wäre, wie viele Einträge tatsächlich vorhanden sind.
4.
Bei fortlaufenden Kalenderdaten und aufsteigend sortierten Kalenderdaten liefert MIN natür-
lich das früheste Datum.
5.
Dasselbe gilt für das mit MAX zu findende Enddatum.
6.
In Zelle K5 wurde der größte vorkommende Messwert ermittelt (vgl. Ziffer 2). Für das Resul-
tat einer MAX -Formel ist es unerheblich, ob dieser Höchstwert nur einmal vorhanden ist oder
mehrfach vorkommt. Anders hingegen sieht es bei der Verwendung der Funktion VERGLEICH
aus, die hier als Ergebnis die Zeilenposition des ersten Vo r k o m m e n s v o n Suchkriterium in der
Suchmatrix liefert. Die Formel =VERGLEICH($K5;rB1.Messwerte;0) als Anweisung: »Suche in der Matrix
mit dem Namen rB1.Messwerte nach dem in Zelle K5 aktuell vorhandenen Suchbegriff (näm-
lich den Maximalwert von rB1.Messwerte ) und zeige an, in welcher Zeile der Matrix er sich
erstmals befindet.« (Ist das Argument Vergleichstyp gleich 0, dürfen die Werte der Matrix in
beliebiger Reihenfolge angeordnet sein.)
HINWEIS
Die Funktion VERGLEICH ist also in vielen Fällen außerordentlich hilfreich, nämlich immer dann,
wenn eine andere Formel (wie z. B. INDEX oder BEREICH.VERSCHIEBEN ) ein Zeilenargument benötigt, das der
Anwender nicht selbst definieren oder vorgeben kann, weil ihm die entsprechende Position unbekannt ist oder
weil sie ständig wechselt.
Im vorgestellten Beispiel die Formel =VERGLEICH(MAX(rB1.Messwerte);rB1.Messwerte;0) zu benutzen scheint hier
naheliegend und eleganter, wäre jedoch kein Vorteil, weil in diesem Fall beide Werte, nämlich der Maximalwert
selbst und seine erste Position, an die Textformeln (vgl. Tabelle 4.2) zu übergeben sind.
Die Formel =INDEX(rB1.Messtage;$M$5;1) übernimmt die zuvor ermittelte Zeilenposition zur
Ermittlung des Datums, an dem der Maximalwert erstmals aufgetreten ist.
7.
Search JabSto ::




Custom Search