Microsoft Office Tutorials and References
In Depth Information
Im Zusammenhang mit Tabelle 4.3:
Die Formel in Zelle L4 ermittelt das Maximum der Messwerte.
Das Ergebnis aus L4 wird in Zelle M4 von der Formel =VERGLEICH($L4;rB1.Messwerte;0) , die den
Namen rB1.MaxPos hat, als Suchkriterium benutzt. Das Ergebnis in M4 ist also eine Zeilen-
position.
Die Formel in K4 wiederum arbeitet mit dem Ergebnis aus rB1.MaxPos , um den zum höchs-
ten Messwert gehörenden Tageszählungswert zu ermitteln.
In Zelle L5 finden Sie eine neue Variante zur Bestimmung des Zeilenarguments einer INDEX -
Formel: Die eingebundene Formel ANZAHL2(rB1.Messwerte) liefert die Anzahl der Messwerte und
damit den Höchstwert einer jeweils aktuellen (und möglicherweise wechselnden) Zeilenzahl.
Das funktioniert natürlich nur dann, wenn Sie voraussetzen können, dass der so geprüfte
Bereich vollständig mit Werten oder mit Formeln gefüllt ist.
Jetzt weiter mit den Strukturen und Formeln, die der Entwicklung des Diagramms dienen. Im
Zusammenhang mit Abbildung 4.17:
Abbildung 4.17 Die Formeln unterhalb von L9 erzeugen die zweite Datenreihe
Wie der variable Diagrammtitel entsteht, haben Sie schon im Beispiel 1 gesehen. Hier nun hat
die entsprechende Zelle K9 zusätzlich den Namen rB1.Titel erhalten. Dies deswegen, weil, wie
später erläutert wird, ein grafisches Objekt mit dieser Zelle zu verknüpfen ist.
Recht interessant für vielerlei Einsatzmöglichkeiten in dynamischen Diagrammen sind Formeln
der Art, wie sie im Bereich L10:L109 angelegt wurden. Hier entsteht eine komplette Datenreihe mit
100 Datenpunkten, von denen letztlich aber nur ein einziger im Diagramm sichtbar sein wird –
der Signalpunkt für den Höchstwert nämlich. Alle anderen kommen nicht zur Anzeige, weil ihr
Wert automatisch auf #NV gesetzt wird. (Zur gezielten Verwendung des Fehlerwerts #NV finden
Sie Informationen und Begründungen in Teil B, Kapitel 11.)
Am Beispiel der Zelle L12 : Die Formel =WENN($I12=rB1.MaxPos;$K12;#NV) als Anweisung: »Wenn der
We r t i n Z e l l e I12 (die fortlaufende Zeilennummer also) gleich dem Wert in der Zelle rB1.MaxPos
Search JabSto ::




Custom Search