Microsoft Office Tutorials and References
In Depth Information
Damit kommt wieder einmal die Funktion BEREICH.VERSCHIEBEN zum Einsatz, diesmal mit all ihren
fünf Argumenten. Eines davon ist Höhe und dafür gibt es im aktuellen Fall eine variable Vorgabe,
nämlich die Zahl in G8 . Die Offset-Formel wird nicht, wie bisher, einen einzelnen Wert ermit-
teln, sondern ein Array aus mehreren Werten definieren und dieses dann der RANG -Formel als
Bezug anbieten.
Am Beispiel der Zelle AC12 : Die Formel
=RANG($AB12;BEREICH.VERSCHIEBEN($AB$12:$AB$23;0;0;$G$8;1);0)
benutzt also die Offset-Formel als Bezugsargument. Nur dieser Formelteil zunächst als Anwei-
sung: »Definiere ein Array (ein eindimensionales Feld mit mehreren Daten). Gehe dazu vom
genannten Bezug AB12:AB23 null Zeilen nach unten oder oben und null Spalten nach links oder
rechts, benutze also den gesamten Bereich (einschließlich seiner dort am unteren Ende ggf. vor-
handenen #NV -Werte). Bilde aus diesem Bereich einen Teilbereich, der so viele Zeilen hoch ist,
wie es als Vorgabe in Zelle G8 steht, und der eine Spalte breit ist.« In G8 steht als Vorgabewert die
Zahl des letzten Monats, der nicht #NV ist! Das so ermittelte Array soll jetzt auch so genannt wer-
den. Dann ermittelt die oben zu sehende RANG -Formel also den Rangplatz des Wertes aus AB12 im
Array.
Sie haben die Formel in den Bereich AC12:AC23 eingegeben. Markieren Sie jetzt in einer davon nur
den BEREICH.VERSCHIEBEN -Teil einschließlich seiner schließenden Klammer. Drücken Sie dann (F9) .
Sie sehen in geschweiften Klammern die zehn Zahlen des aktuell benutzten Arrays. Die #NV -
Werte aus dem referenzierten Gesamtbereich AB12:AB23 sind per Höhendefinition (bitte nur die
ersten zehn von den zwölf) ausgeschlossen. Deshalb kann also die RANG -Formel richtig arbeiten,
unabhängig davon, wie viele #NV -Werte es am unteren Ende ihres Bezugs aktuell gibt. Drücken
Sie (Esc) , um den Prüfmodus zu verlassen.
HINWEIS
Die Funktion BEREICH.VERSCHIEBEN verfügt neben dem hier benutzten Argument Höhe auch über
das Argument Breite . Deshalb kann sie auch Matrizen erzeugen und mit diesen nach Belieben kalkulieren, wie
z. B. in =SUMME(BEREICH.VERSCHIEBEN(Bezug;Zeilen;Spalten;Höhe;Breite)) .
Damit ist die Formeleingabe in die drei gruppierten Quelldatenblätter abgeschlossen.
Heben Sie die Gruppierung auf und kontrollieren Sie, ob alle Formeln in allen drei Blättern
an der richtigen Stelle angekommen sind.
Prüfen Sie, ob in Zelle S5 jeweils die richtige Ziffer (1, 2, 3) für die Tarifermittlung steht.
Aktivieren Sie Daten 3 und löschen Sie die Formeln im Bereich der Eurowerte der Gruppe G ,
also in AA12:AA23 . Dadurch werden die Berechnungen in den Spalten AB und AC wieder von
#NV befreit. Befriedigend ist das so nicht. Aber es soll auch nicht weiter stören. Jedenfalls jetzt
noch nicht. In Kapitel 6 allerdings wird dazu eine bessere Lösung zu suchen sein.
Search JabSto ::




Custom Search