Microsoft Office Tutorials and References
In Depth Information
Damit zu den Details:
Frage: Warum gibt es neue Namen wie rB1.AuswahlKeine01 und rB1.QuelleD01 ? (Die Suffixen-
dung D01 steht hier für »erste Datenquelle« in Abgrenzung zu D02 für »zweite Datenquelle«
oder z. B. P01 für »erste Parameterquelle« und Ähnliches.)
Antwort: Damit die sich darauf beziehenden Formeln »sprechender«, damit leichter prüfbar
und korrigierbar werden. Das ist am besten mit einem Beispiel zu verdeutlichen, der verglei-
chenden Betrachtung zweier funktionsgleicher Formeln.
Die Ursprungsfassung in Zelle L12 der Datei 0503_Vergleich3Jahre02 :
=WENN(rL1.Gruppen01Ausw=L$2;#NV;
BEREICH.VERSCHIEBEN(INDIREKT(L$7);$G12;rL1.Gruppen01Ausw))
Die funktionsgleiche Neufassung in Zelle L15 der Datei 0601_Vergleich01 :
=WENN(rL1.Gruppen01Ausw=rB1.AuswKeine01;#NV;
BEREICH.VERSCHIEBEN(INDIREKT(rB1.QuelleD01);$G15;rL1.Gruppen01Ausw))
Die zweite »erzählt« sehr viel deutlicher, was sie macht, und ist deshalb leichter zu verstehen, als
wenn Sie bei einer Überprüfung oder einer Fehlersuche erst einmal nachschauen müssten, was
in Zelle L2 oder in Zelle L9 vorhanden ist bzw. generiert wird.
Der Bereich P14:R26 bildet die Grundlage für das Diagramm im Blatt Focus 2 . Es handelt sich dort
um mit Focus 1 identische Einstellungen, lediglich die gezeigten Werte sind andere – nicht Stun-
den, sondern Tariferlöse. Somit gilt: Wenn gleichartige Abrufe, dann auch gleichartige Formeln.
Deswegen kann ich mich hier auf wenige Ausführungen zu Neuerungen und Unterschieden
beschränken:
Die Legendenbeschriftungen in Q14:R14 werden mit Formeln eins zu eins aus L14:M14 über-
nommen.
Die Formeln in Q15:R26 benutzen dieselben Jahres- und Gruppeneinstellungen wie ihre Nach-
barn in den Spalten L und M. Sie ermitteln Daten aus jeweils derselben Quelle, jedoch von
anderer Stelle.
Zum besseren Verständnis des Letztgenannten ein kurzer Ausflug ins Blatt Daten 1 :
Dort befindet sich, wie schon bekannt, der rD1.Knoten in Zelle K11 .
In der Hilfszeile 3 wurde eine durchlaufende Nummerierung angelegt. Mit ihr wird gezeigt,
welche Spalte wie viele Spalten vom Knoten entfernt ist (vgl. dazu auch Abbildung 6.4).
Wenn der Anwender im Steuerelement zur Auswahl einer Gruppe auf den Eintrag Gruppe C
klickt, auf den dritten Listeneintrag also, muss der entsprechende Formelzugriff vom Knoten
aus gesehen die dritte Spalte ansprechen. So weit gilt das jedenfalls, wenn der Formelzugriff
die Stundenwerte in den Spalten L:R betrifft.
Search JabSto ::




Custom Search