Microsoft Office Tutorials and References
In Depth Information
Wenn jedoch ein Formelzugriff auf Basis desselben »Klickresultats« (also Ziffer 3 in der mit
dem Steuerelement verknüpften Zelle) statt der Stundenwerte in Spalte N die gruppenspezifi-
schen Tariferlöse in Spalte W »erwischen« soll (jetzt 12 statt 3 Spalten vom Knoten entfernt),
gibt es zwei Möglichkeiten:
Sie richten in jedem Quelldatenblatt einen zweiten Knoten ein. Damit aber machen Sie
etliche Formeln des gesamten Modells komplizierter als bisher – bei diesem kleinen
Datenmodell ein eher unangemessener Schritt.
Sie benutzen ein »Additiv«, mit dem Sie das Klickresultat den Anforderungen anpassen.
Im Beispiel wurde die zweite Variante als sehr viel einfacher und übersichtlicher gewählt. Damit
nun zurück ins Blatt Basis 1 . Im Zusammenhang mit Abbildung 6.6, am Beispiel der Formel in
Zelle Q15 :
=WENN(rL1.Gruppen01Ausw=rB1.AuswKeine01;#NV;
BEREICH.VERSCHIEBEN(INDIREKT(rB1.QuelleD01);$G15;rL1.Gruppen01Ausw+Q$11))
Hier wird am Schluss des BEREICH.VERSCHIEBEN -Teils der Formel, beim Spaltenargument also, dem
Vorgabewert aus der Zelle rL1.Gruppen01Ausw (dem Klickresultat) so viel hinzugezählt, wie in
der Zelle Q11 als »Zuschlag« hinterlegt ist. Um im oben erwähnten Beispiel zu bleiben: Nicht drei
Spalten vom Knoten, sondern 3+9, also zwölf Spalten vom Knoten entfernt soll die Formel
zugreifen.
Es handelt sich hier also um eine Veränderung einer vom Benutzer mittels Steuerelement
erzeugten Vorgabe. Um diesen Ausnahmefall klar zu kennzeichnen, wurden die Zellen Q11:R11
deutlich von den anderen Hilfszellen abweichend formatiert und zusätzlich mit der Überschrift
S_Offset + versehen, gemeint damit ist also eine Addition zum Spaltenoffset.
Formatierungen in den Focusblättern
Dem Modell wurde ein zweites Focusblatt hinzugefügt. Es ist in formaler Hinsicht mit dem
ersten weitestgehend identisch. Unterschiedlich sind lediglich
die Untertitel in der Überschriftenzeile,
die Positionen der Navigationspfeile und
die Formatierungen der Größenachsen der Diagramme.
Die festen Skalierungen der Größenachsen und die dort benutzten Zahlenformate in der Über-
sicht:
Minimum
Maximum
Hauptintervall
Zahlenformat
Focus 1
0
1.600
400
#.##0" h";;
Focus 2
0
2.000.000
250.000
#.##0." T€";;
Search JabSto ::




Custom Search