Microsoft Office Tutorials and References
In Depth Information
Im Zusammenhang mit Abbildung 8.16 und der dortigen Nummerierung:
1. Geben Sie in die hellgelbe Zelle E8 ein beliebiges Datum ein. Durch fortzählende Formeln
entsteht eine Reihe von 50 Kalendertagen. Der entsprechende Gesamtbereich hat den Namen
rD2.Kalender .
2. Benutzen Sie das Steuerelement (eine ScrollBar aus der Gruppe der ActiveX-Steuerelemente ),
um einen der 50 Kalendertage auszuwählen.
3. Die Zelle E2 mit dem Bereichsnamen rD2.DatumAusw ist die LinkedCell der ScrollBar .
4. Die Formel in Zelle F3 wird weiter unten noch näher betrachtet. Sie führt, als Kernstück dieses
Beispiels, in rD2.Summierbereich (den Zellen F8:F57 ) eine Summierung aus, die sich vom ersten
Tag des Kalenders bis zum per Steuerelement ausgewählten Tag (einschließlich) erstreckt. Eine
wandernde Formatierung zeigt den Bereich an, dessen Summe in Zelle F3 erscheint. Mit der
ScrollBar können Sie, z. B. bei Dauerdruck auf einen ihrer Pfeile, diese Formatierung (und
damit den summierten Bereich) wie eine Jalousie nach unten und oben fahren lassen.
5. Was dort nach unten und oben fährt, bewegt sich im zugehörigen Liniendiagramm nach
links oder nach rechts. Im indirekt formulierten Zusammenhang: Sie beeinflussen mit einem
Steuerelement die Länge einer Datenreihe in einer variablen Ausdehnung zwischen 1 und
50 Datenpunkten. (Wenn Sie die Reihe auf nur den ersten Datenpunkt verkürzen, wird die-
ser, jedenfalls bei der gewählten Formatierungsart, nicht sichtbar sein.)
Die Ursachen solcher Dynamik finden Sie in Spalte G. Dort befindet sich, unsichtbar formatiert,
die Datenquelle des Diagramms. Eine nähere Beschreibung unterbleibt hier, denn die benutzte
Taktik war, jedenfalls sinngemäß, bereits in Kapitel 6 ein Thema (vgl. Abbildungen 6.24 und
6.25 und damit zusammenhängende Texte).
Zu einigen der Formeln in den Spalten E und F:
Mit =INDEX(rD2.Kalender;rD2.DatumAusw;1) wird in Zelle E3 (die den Namen rD2.DatumEnde hat), das
Datum ermittelt, das der aktuellen Einstellung der ScrollBar entspricht.
Die Formel in Zelle F3
=SUMMEWENN(rD2.Kalender;"<="&rD2.DatumEnde;rD2.Summierbereich)
erzeugt in ihrem zweiten Argument ein Suchkriterium, das die seriellen Zahlen der Kalender-
daten vergleicht. Wenn in der Zelle rD2.DatumEnde z. B. das Datum 18.06.2010 stünde, würden
Sie, nachdem Sie in der Formel den Teil "<="&rD2.DatumEnde markiert und dann (F9) gedrückt hät-
ten, das Suchkriterium "<=40347" entdecken.
HINWEIS
An dieser Stelle sei nochmals ein unmittelbarer Vergleich zwischen einer rS1-Bereichsnamen ver-
wendenden Formel und derselben Formel in konventioneller Schreibweise erlaubt:
=SUMMEWENN(rD2.Kalender;"<="&rD2.DatumEnde;rD2.Summierbereich)
=SUMMEWENN($E$8:$E$57;"<="&$E$3;$F$8:$F$57)
Das Ergebnis wäre identisch, die Interpretierbarkeit ist – nun ja – unterschiedlich.
Search JabSto ::




Custom Search