Microsoft Office Tutorials and References
In Depth Information
Funktionen
Die im Buch behandelten oder erwähnten Funktionen werden nachstehend in alphabetischer
Reihenfolge beschrieben.
ANZAHL
Die Funktion =ANZAHL(Bezug) zählt in Bezug nur Zahlen.
Der Bezug kann Daten unterschiedlichen Typs enthalten oder sich auf Daten unterschiedlichen
Typs beziehen, für die Zählung werden aber nur Zahlenwerte berücksichtigt.
ANZAHL2
Die Funktion =ANZAHL2(Bezug) zählt die Häufigkeit von Einträgen verschiedener Art in Bezug . Als
Eintrag gilt hierbei eine beliebiger Zellinhalt, auch sog. leerer Text ( "" ).
WICHTIG
Das folgende Beispiel verweist auf ein gelegentlich vorkommendes Problem:
1.
Sie haben in einem Bereich mit WENN -Formeln gearbeitet, die entweder eine Zahl oder leeren Text ausgeben,
z. B. =WENN($B2>=rP1.Sollwert;$B2;"") . Ein Teil der Zellen enthält im Ergebnis also Zahlen, ein anderer Teil leeren
Text (scheinbar nichts).
Sie kopieren den Bereich in die Zwischenablage und fügen ihn an anderer Stelle mit der Option Inhalte einfü-
gen/Werte wieder ein.
2.
Im so eingefügten Bereich sind nun Zahlen und scheinbar leere Zellen enthalten – Letztere enthalten nichts
Sichtbares und, natürlich, auch kein Leerzeichen. Dennoch werden sie bei Verwendung der Funktion ANZAHL2
mitgezählt, denn für Excel ist leerer Text eben nicht nichts , sondern ein Wert.
3.
BEREICH.VERSCHIEBEN
Die Funktion =BEREICH.VERSCHIEBEN(Bezug;Zeilen;Spalten;Höhe;Breite) – im englischen Original schlicht
und einleuchtender als OFFSET bezeichnet – spielt im Teil A des Buches eine sehr große Rolle und
wird in mehreren Kapiteln vorgestellt. Entsprechende Formeln sind dort häufig auch als Offset-
Formeln bezeichnet. Sie liefert als Ergebnis einen Wert, der sich in einer Zelle befindet, die
gegenüber dem angegebenen Argument Bezug um eine bestimmte Anzahl von Zeilen und Spalten
versetzt ist. Das Argument Bezug definiert also den Ausgangspunkt für einen Zugriff auf eine
andere Zelle oder einen Zellbereich.
Die Argumente Zeilen und Spalten können auch negative Zahlen sein, dann erfolgt der Offset von
Bezug aus nach oben bzw. nach links. Sie können mit der Formel also von jeder Stelle eines Arbeits-
blatts aus jede andere Stelle in diesem Arbeitsblatt (oder in anderen Blättern) ansprechen.
Die Argumente Höhe und Breite sind optional. Sie werden dann gebraucht, wenn die Formel eine
Matrix definieren soll, die gegenüber Bezug um eine bestimmte Anzahl von Zeilen und Spalten
versetzt ist und die eine bestimmte Höhe (Zeilenzahl) und Breite (Spaltenzahl) aufweisen soll. In
solchen Fällen wird die Funktion meistens in eine andere eingebunden.
Search JabSto ::




Custom Search