Microsoft Office Tutorials and References
In Depth Information
INDEX
Die Funktion INDEX hat zwei unterschiedliche Syntaxen, von denen in diesem Buch aber nur die
erste, nämlich =INDEX(Matrix;Zeile;Spalte) , benutzt wird. Ermittelt wird ein Wert aus einer vorgegebe-
nen Matrix (aus einem zweidimensionalen Zellbereich). Die Lokalisierung des zu ermittelnden
Wertes wird innerhalb der Matrix durch die numerische Angabe von Zeile und Spalte erreicht.
Die Funktion INDEX ist immer dann besonders gut einsetzbar, wenn eine Matrix bekannt und
konstant ist, sich die zu ermittelnden Werte also nicht an von Fall zu Fall unterschiedlichen
Positionen befinden. Dass die Funktion allerdings mit ihrem Argument Matrix auf einen definier-
ten Zellbereich angewiesen ist, macht sie deutlich weniger flexibel als BEREICH.VERSCHIEBEN .
INDIREKT
Mit der Funktion =INDIREKT(Bezug;A1) können Sie einen Text, der in Bezug , in einer Zelle außerhalb
einer beliebigen Formel steht, als Bezugsargument innerhalb dieser Formel benutzen. In vielen
meiner Modelle verwende ich INDIREKT zur Herstellung dynamischer Bezüge, nämlich zur Defini-
tion variabler Bezugsargumente. Entsprechende Beispiele finden Sie in den Kapiteln 4 und 5.
In der Syntax =INDIREKT(Bezug;A1) steht das optionale Argument A1 für einen Wahrheitswert, der
angibt, welche Bezugsart in der Zelle enthalten ist ( WAHR für die A1 -Schreibweise, FALSCH für die
Z1S1 -Schreibweise). Da Letztere in Modellen dieses Buches keine – und auch sonst kaum eine –
Rolle spielt, kann das Argument unberücksichtigt bleiben (was dann von Excel als WAHR inter-
pretiert wird).
ISTFEHLER
Die Funktion =ISTFEHLER(Wert) liefert das Ergebnis WAHR , wenn Wert ein Fehlerwert (wie z. B. #NV,
#WERT!, #BEZUG!, #DIV/0!, #ZAHL! oder #NAME? ) ist, wenn also z. B. ein Bezug einen solchen Fehler
enthält oder, bei einer Fehlerpufferung, die Vorprüfung einer Berechnung einen solchen Fehler
ergibt (vgl. Abschnitt »Fehleranzeigen und mögliche Ursachen« am Ende dieses Kapitels).
Anwendungsbeispiel: =WENN(ISTFEHLER($C2/$B2);"";$C2/$B2) dient zur #DIV/0! -Fehlerpufferung unter
Excel 2003. Zur gleichartigen, aber einfacheren Verwendung unter Excel 2010 siehe weiter unten
bei WENNFEHLER .
ISTLEER
Die Funktion =ISTLEER(Bezug) prüft, ob Bezug leer ist, und reagiert mit dem Ergebnis WAHR oder
FALSCH .
Eine Zelle, die leeren Text enthält (vgl. oben Funktion ANZAHL2 ) ist nicht leer. ISTLEER liefert bei
Bezug auf eine solche Zelle also das Ergebnis FALSCH .
ISTNV
Die Funktion =ISTNV(Bezug) prüft, ob in Bezug der Wert #NV steht, und reagiert mit dem Ergebnis
WAHR oder FALSCH .
Search JabSto ::




Custom Search