Microsoft Office Tutorials and References
In Depth Information
2. Markieren Sie den Bereich H5:S13 und beginnen Sie in der Bearbeitungsleiste mit der Eingabe
einer Formel. Fügen Sie unter Excel 2010 die Formel, wie oben beschrieben, aus einer Vorga-
beliste mit (ÿ) ein oder schreiben Sie =summewenn( bis zur öffnenden Klammer und benutzen
Sie dann die Tastenkombination (Strg) + (ª) + (A) , um die komplette Syntax dieser Funktion
einzulesen, nämlich =SUMMEWENN(Bereich;Suchkriterien;Summe_Bereich) .
3. Das Argument Bereich ist markiert. Ziehen Sie mit der Maus über die Zellen F14:F32 . Hier – nur
hier – kann Excel die Suchkriterien finden. Deswegen muss dieser Bezug absolut werden, also an
vier Stellen mit dem Dollarzeichen versehen werden. Die geben Sie natürlich nicht manuell ein.
Der Cursor blinkt hinter dem Bezug. Drücken Sie (F4) (beim »Vertippen« ggf. mehrfach), bis
die Formel bis hierhin =SUMMEWENN($F$14:$F$32;Suchkriterien;Summe_Bereich) lautet.
4. Doppelklicken Sie auf das Argument Suchkriterien und klicken Sie mit der Maus auf die Zelle F5 .
Hier steht das zeilenrelevante Suchkriterium. Bei der späteren Übertragung und Anpassung
der Formel muss der Zeilenbezug variabel bleiben, der Spaltenbezug hingegen nicht (die
Suchkriterien stehen alle und nur in Spalte F). Deswegen muss dieser Bezug spaltenabsolut
werden. Drücken Sie also (F4) , bis die Formel =SUMMEWENN($F$14:$F$32;$F5;Summe_Bereich) lautet.
5. Doppelklicken Sie auf das Argument Summe_Bereich und ziehen Sie mit der Maus über die
vorhandenen Januar-Werte, also über den Bereich H14:H32 . Hier stehen die zu summierenden
Konstanten, von denen einige dem Suchkriterium entsprechen. Bei der späteren Übertragung
und Anpassung der Formel muss der Spaltenbezug variabel bleiben, der Zeilenbezug hingegen
nicht (die zu summierenden Daten stehen alle und nur in den Zeilen 14 bis 32). Deswegen also
muss dieser Bezug zeilenabsolut werden. Drücken Sie also (F4) , bis die Formel ihre endgültige
und jetzt drei Bezugsarten beinhaltende Fassung hat: =SUMMEWENN($F$14:$F$32;$F5;H$14:H$32) .
6. Kontrollieren Sie sorgfältig, ob das alles so stimmt. Insbesondere sind natürlich die Bezugs-
varianten, also die richtigen Positionen der Dollarzeichen in der Formel, von unverzichtbarer
Bedeutung.
7. Okay, alles in Ordnung? Der nächste Schritt ist nun denkbar einfach und sehr effizient: Über-
tragen Sie mit Mehrfacheingabe, also mit (Strg) + (¢) , die Formel in den markierten Bereich
H5:S13 . Alle der auf diese Weise erzeugten 108 Formeln haben sich richtig angepasst und die
Farbformate der Zeilen sind bei dieser Aktion erhalten geblieben. Fertig.
Fertig? Halt, halt, halt! Sind Sie denn sicher, dass sich die Formeln richtig angepasst haben? Sind
Sie sicher, dass die blau oder magenta gefärbten Zahlen tatsächlich die gewünschten Gesamt-
und Zwischensummen zeigen? Sind Sie nicht. Also müssen Sie das prüfen. Dazu empfehle ich
für solche einfachen Standardmodelle drei von mehreren möglichen Methoden:
Formelergebnisse und Formelargumente untersuchen
Die erste der Methoden wurde oben schon vorgestellt: Visualisieren Sie, zunächst von der Zelle H5
ausgehend mit Spur zum Vorgänger die in dieser Zelle vorhandenen Formelbezüge. Das daraus
entstehende Bild ist sehr übersichtlich und entspricht den Linien und Rahmungen in Abbildung
1.16. Es ist deutlich zu erkennen, welchen Bereich Excel auf das Vorhandensein der Suchkriterien
prüft, welches Suchkriterium aus welcher Zelle dabei Verwendung findet und aus welchem Bereich
dann die relevante Summe gebildet wird. Wiederholen Sie probeweise dann den Vorgang für
einige andere Zellen und besonders – das mache ich auf jeden Fall immer – für die letzte Zelle des
Formelblocks, also für S13 . Anschließend löschen Sie mit Pfeile entfernen die erzeugten Spuren.
Search JabSto ::




Custom Search