Microsoft Office Tutorials and References
In Depth Information
»interne Wahrnehmung« dieses Formelteils, nämlich ein in geschweiften Klammern darge-
stelltes Array, wie es sich aus dem Bezug $F$14:$F$32 ergibt. Das also sind alle Texte, in denen
Excel auf Übereinstimmung mit dem Suchkriterium prüft. Drücken Sie die Taste (Esc) , um
zur ursprünglichen Darstellung der Formel zurückzukehren.
2. Klicken Sie in der Syntaxanzeige auf das Argument Suchkriterien , um diesen Teil der Formel zu
markieren. Nach dem Drücken von (F9) zeigt Ihnen Excel, welchen Text es in diesem Teil der
Formel benutzt, nämlich den Inhalt der Zelle F5 . Drücken Sie die Taste (Esc) , um den Prüf-
modus zu verlassen.
3. Mit dem dritten und letzten Teil der Formel wird genauso verfahren. Hier kommt also das
Array jener Zahlen zum Vorschein, auf die Excel bei dieser Art der Summierung selektiv
zugreift. Zum Abschluss (Esc) nicht vergessen.
Dieses Verfahren ist nicht immer anwendbar. Wenn die Zeichenfolgen der nach (F9) erzeugten
Arrays zu groß sind, um sie als Inhalt einer einzigen Zelle darstellen zu können, reagiert Excel
mit einer entsprechenden Fehlermeldung: » Formel ist zu lang «.
Zwei weitere Beispiele der gleichen Anwendungsart zum Prüfen von Formelinhalten oder zum
schnellen Entdecken von Formelfehlern:
Mit einer Formel wie =REST($D29-$C29;1)*24 errechnen Sie die Dezimalstunden einer Zeitspanne zwi-
schen zwei Uhrzeiten, die in C29 und D29 stehen (20:00 Uhr bis 03:38 Uhr des Folgetages, inhaltlich
mehr dazu im nächsten Kapitel). Wenn Sie die einzelnen Formelteile wie nachstehend aufgelistet
markieren und dann mit (F9) jeweils die Werteanzeige dieser markierten Teile abrufen (danach
immer wieder (Esc) !), könnten Sie z. B. folgende Darstellung in der Bearbeitungsleiste sehen:
=REST($D29-$C29;1)*24
Beispiel zur Ansicht in der Bearbeitungsleiste nach Drücken von (F9) :
Markierter Teil:
$D29
=REST(0,151388888888889-$C29;1)*24
$C29
=REST($D29-0,833333333333333;1)*24
$D29-$C29
=REST(-0,681944444444444;1)*24
REST($D29-$C29;1)
=0,318055555555556*24
REST($D29-$C29;1)*24
=7,63333333333333 (also 7,63 Dezimalstunden)
Angenommen, bei der Formel
=SUMME(BEREICH.VERSCHIEBEN(rB1.KstGesamt;0;0;rL1.QuartalAusw;rL1.Kum01Ausw))
ist bedauerlicherweise keine Zahl, sondern der Fehlerwert #NAME? das Ergebnis. Dass Excel einen
der drei benutzten Bereichsnamen nicht interpretieren kann, ist also naheliegend. Aber welcher
davon ist der Übeltäter? Das ist in der Formel selbst nicht zu erkennen. Schnell fündig aber wer-
den Sie, wenn Sie die Bereichsnamen in der Formel einzeln markieren und mit (F9) prüfen, ob
dieser Teil der Formel den Fehler liefert. Aber Achtung: Prüfen Sie besser gleich alle drei Namen,
denn ein solcher Namensfehler könnte hier ja mehrfach vorhanden sein.
Search JabSto ::




Custom Search