Microsoft Office Tutorials and References
In Depth Information
HINWEIS
In der auf der CD-ROM verfügbaren Datei 0204_Kalender01_FERTIG_1 sind in der Spalte FT nur
die bundesweit gültigen deutschen Feiertage des Jahres 2010 markiert (mit F ) und im Dezember einige Tage mit
Betriebsferien ( BF ).
Der erste der folgenden Arbeitsschritte ist potenziell überflüssig, soll Ihnen aber dennoch zuge-
mutet werden, um eine neue Formelvariante einzuführen und die daraus zu ziehenden Erkennt-
nisse auf eine weitere Ausstattung des Kalenders übertragen zu können:
Die temporäre Werteanzeige in der Spalte Minuten soll nur dort Zahlen erzeugen, wo ihr in
Spalte FT kein Eintrag gegenübersteht.
Danach sollen auch alle Zeilen, die gemäß Eintrag in Spalte FT kein Arbeitstag sind, eine
andere Farbformatierung erhalten.
Markieren Sie sämtliche Inhalte in der Spalte Minuten . Aktive Zelle ist P16 . Überschreiben Sie
die dort enthaltene Formel =ZUFALLSBEREICH($V$10;$V$11) mit der nachstehend gezeigten und
geben Sie sie dann mit (Strg) + (¢) für den gesamten Spaltenbereich ein. Im Ergebnis wer-
den nur jene Zeilen Werte anzeigen, die in Spalte FT nicht als arbeitsfrei gekennzeichnet sind.
5.
=WENN(ODER(NICHT(ISTLEER($L16));$M16=1;$M16=7);
"";
ZUFALLSBEREICH($V$10;$V$11))
Als umgangssprachliche Anweisung: »Prüfe, ob die Zelle L16 nicht leer ist oder ob in M16 der
Wert 1 steht (für den Sonntag) oder ob in M16 der Wert 7 steht (für den Samstag). Wenn auch
nur eine dieser Vorgaben zutrifft, dann erzeuge leeren Text. Ansonsten, wenn also keine der Vor-
gaben zutrifft, dann erzeuge eine zufällige Ganzzahl im Bereich der in V10 und V11 definierten
Spanne.«
Sie sollten das Ergebnis testen. Geben Sie in Spalte FT an beliebiger Stelle beliebige Zeichen ein.
Der zeilengleiche Wert in der Spalte Minuten verschwindet. Entfernen Sie die Zeichen, um wie-
der einen Wert errechnen und anzeigen zu lassen. Wie schon gesagt: Das war eher überflüssig,
führt aber nach Prinzip und Inhalt zum Arbeitsschritt 6, dem ich, weil er ein neues Thema bein-
haltet, einen eigenen kleinen Abschnitt widme.
Bedingte Formatierung
Er soll nun eine bedingte Formatierung eingerichtet werden, die für den gesamten Kalender-
datenbereich gilt und die jeder Zeile eines arbeitsfreien Tages eine spezielle Formatierung zuweist.
Das soll hier mittels einer Formel eingerichtet werden. Im Zusammenhang mit Abbildung 2.19
und Abbildung 2.20:
Search JabSto ::




Custom Search