Microsoft Office Tutorials and References
In Depth Information
2.4.7 Zellformat »Zahlen«
Zur Erläuterung:
Mit Hilfe der bereits bekannten Eigenschaft Value bekommen die Zel-
len A1 und A2 jeweils einen Zahlenwert zugewiesen.
Value
Bei Zahlen mit Nachkommastellen ist ein Punkt statt eines Kommas
einzutragen.
Punkt statt
Komma
Die Formel =SUMME(A1:A2) wird als Wert der Eigenschaft Formula-
Local in der von Excel gewohnten Form (in Deutsch) eingetragen. In
der Bearbeitungszeile ist erkennbar, dass der Inhalt der Zelle A3 nach
wie vor eine Formel ist.
FormulaLocal
Bei Datumsangaben dürfen die Anführungsstriche nicht fehlen. Es
empfiehlt sich, die amerikanische Schreibweise zu benutzen, dann
werden die Werte direkt als Datumsangaben erkannt und formatiert
(führende Nullen).
Datum
Die Formel =A4-A5 dient zur Berechnung der Tagesdifferenz zwischen
den beiden Datumsangaben.
Der Inhalt der Zelle A7 ist wiederum ein Zahlenwert.
2.4.7
Zellformat »Zahlen«
Mit folgender Prozedur werden die Formate für Zahlen, Datumsangaben
und Prozentzahlen in Zellen eingetragen:
Format eintragen
Sub ZellformatZahlen()
ThisWorkbook.Worksheets("Tabelle2").Activate
' Zahl
Range("A1:A3").NumberFormatLocal = "#.##0,00 €"
' Datum
Range("A4:A5").NumberFormatLocal = _
"TTTT, ""den"" TT. MMMM JJ"
Range("A6").NumberFormatLocal = "0 ""Tage"""
' Prozent
Range("A7").NumberFormatLocal = "0,00 %"
End Sub
Das Ergebnis sehen Sie in Abbildung 2.26.
Search JabSto ::




Custom Search