Microsoft Office Tutorials and References
In Depth Information
5.9 WENNFEHLER
122
5 Logische Funktionen
In den Zeilen 7 und 10 liegt die Anzahl der Kunden noch nicht vor. Wenn Sie hier
nur den Rechenschritt B7/C7 durchführen würden, käme die Fehlermeldung
#DIV/0. Die Funktion WENNFEHLER merkt, dass ein Fehler erscheint, und bringt
dann das Leerzeichen. Sobald in C7 eine Zahl ungleich 0 eingegeben wird, erscheint
das Ergebnis.
Eine Nummer ist nicht vorhanden
Sie müssen mit der Funktion SVERWEIS nach Nummern suchen. Sollte eine
Nummer nicht in der Suchmatrix sein, liefert SVERWEIS das Ergebnis #NV. In
Verbindung mit der Funktion WENNFEHLER können Sie die Fehlermeldung
unterdrücken.
Öffnen Sie die Datei WENNFEHLER.XLSX , aktivieren Sie das Tabellenregister
Wennfehler_2 und markieren Sie die Zelle F6.
Starten Sie den Funktions-Assistenten und aktivieren Sie die Funktion
WENNFEHLER.
Geben Sie ins Feld Wert den folgenden Rechenschritt ein:
SVERWEIS(E6;$A$6:$C$21;2;0)
Klicken Sie ins Feld Wert_falls_Fehler und geben Sie dort den Text "Nummer
nicht in der Liste" ein.
=WENNFEHLER(SVERWEIS(E6;$A$6:$C$21;2;0);" Nummer nicht in der Liste")
Kopieren Sie die Formel nach unten.
Bild 5.9: Die Funktion
WENNFEHLER
unterdrückt die
Anzeige des #NV-
Fehlers.
Die Nummer 10 ist nicht in der Liste der Nummern vorhanden. Normalerweise
würde die SVERWEIS-Funktion als Ergebnis #NV liefern. Durch die
WENNFEHLER-Funktion wird der Text "Nummer nicht in der Liste" angezeigt.
Search JabSto ::




Custom Search