Microsoft Office Tutorials and References
In Depth Information
3.7 KLEIN
58 3 Mit Textfunktionen arbeiten
Bestätigen Sie mit OK .
Der Funktionsaufbau:
=LÄNGE(A7)
Kopieren Sie die Funktion nach unten.
Bild 3.15: Die Funktion LÄNGE zählt die
Anzahl der Zeichen in der Zelle.
Das Ergebnis zeigt jetzt die genaue Anzahl der Zeichen inklusive Leerzeichen in
einer Zelle.
Artikelnummern automatisch auffüllen
Müssen Ihre Artikelnummern beispielsweise immer sechsstellig sein und möchten
Sie sie nun automatisch mit Nullen auffüllen lassen, wenn sie vierstellig sind, wäre
ein gewünschtes Ergebnis von 1234 nach 123400. Das folgende Beispiel finden Sie
auf dem Register Länge_2. Mit einer WENN-Funktion prüfen Sie, ob die Artikel-
nummer vierstellig ist. Wenn ja, dann werden zwei Nullen an die Artikelnummer
angehängt. Andernfalls wird die Artikelnummer angezeigt.
=WENN(LÄNGE(A2)=4;A2&"00";A2)
Der erste Teil der WENN-Funktion prüft mit der Funktion LÄNGE, ob die Artikel-
nummer vierstellig ist:
WENN(LÄNGE(A2)=4;
Sollte dies zutreffen, dann werden zwei Nullen an den Inhalt der Zelle gehängt.
A2&"00";
Search JabSto ::




Custom Search