Microsoft Office Tutorials and References
In Depth Information
3.7 KLEIN
3.8 LÄNGE
59
Wenn die Artikelnummer aus sechs Stellen besteht, wird nur der Inhalt der Zelle
genommen.
A2)
Bild 3.16:
Die Artikelnummer soll
mit Nullen aufgefüllt
werden, wenn sie nur
aus vier Zeichen
besteht.
Das Ergebnis zeigt jetzt jede Artikelnummer sechsstellig.
Das automatische Auffüllen bei unterschiedlicher Länge
Das folgende Beispiel zeigt das Auffüllen von Nullen, bei unterschiedlicher Anzahl
von Zellen. Sie finden das Beispiel auf dem Register Länge_3 .
=WENN(LÄNGE(A2)<>6;A2&WIEDERHOLEN(0;6-LÄNGE(A2));A2)
Der erste Teil der WENN-Funktion prüft mit der Funktion LÄNGE, ob die Arti-
kelnummer ungleich 6 Zeichen ist.
WENN(LÄNGE(A2)<>6;
Sollte dies zutreffen, wird die Zahl 0 sooft wiederholt, bis die sechs Zeichen aufge-
füllt sind, und diese Anzahl Nullen wird an den Inhalt von A2 angehängt.
A2&WIEDERHOLEN(0;6-LÄNGE(A2));
Wenn die Artikelnummer aus sechs Stellen besteht, wird nur der Inhalt der Zelle
genommen.
A7)
Search JabSto ::




Custom Search