Microsoft Office Tutorials and References
In Depth Information
En B4 , saisissez tout d’abord un nom, présent sur le tableau, par
exemple MONOD .
En B5 , saisissez la formule suivante, pour obtenir le prénom :
=RECHERCHEV(B4;Données!A2:G31;2;FAUX)
Figure 6.14 : L’affichage du prénom
La fonction RECHERCHEV va « scruter » la première colonne de la
plage Données!A2:G31 (deuxième paramètre), à la recherche du
contenu de B4 (premier paramètre), ici MONOD . Elle s’arrêtera dès
qu’elle aura trouvé la première occurrence de MONOD et renverra le
contenu de la cellule située sur la même ligne, mais dans la
deuxième
colonne
(troisième
paramètre)
de
la
plage
Données!A2:G31 , soit le prénom correspondant.
Le dernier paramètre, ici égal à FAUX , joue un rôle très important
dans la recherche. En effet, s’il est égal à VRAI , la fonction « s’ar-
rêtera » à la première valeur immédiatement inférieure à la valeur
cherchée. Cela nécessite que la plage de cellules dans laquelle
s’effectue la recherche soit triée par ordre croissant. En revanche,
si cet argument est FAUX , RECHERCHEV recherchera une correspon-
dance exacte. S’il n’en trouve pas, le message d’erreur #N/A sera
renvoyé. Dans notre cas, il est nécessaire d’effectuer une recher-
che exacte. Le paramètre spécifié est donc égal à FAUX .
Pour continuer la mise à jour de la fiche, saisissez les formules
suivantes :
j En B6 :
=RECHERCHEV(B4;Données!A2:G31;3;FAUX)
j En B7 :
=RECHERCHEV(B4;Données!A2:G31;4;FAUX)&"-"&
RECHERCHEV(B4;Données!A2:G31;5;FAUX)
j En B8 :
=RECHERCHEV(B4;Données!A2:G31;6;FAUX)
Search JabSto ::




Custom Search