Microsoft Office Tutorials and References
In Depth Information
j En B9 :
=RECHERCHEV(B4;Données!A2:G31;7;FAUX)
Vous obtenez ainsi une fiche de contact complète, présentant de
façon plus conviviale les données de la tableau. Notez que le
résultat de la fonction RECHERCHEV peut être intégré dans une
formule (ce qui a été fait pour juxtaposer le code postal et la ville,
en B7 ).
Figure 6.15 : La fiche de contact complète
Recherche selon plusieurs critères
Si deux personnes portent le même nom, la recherche s’arrêtera sur
le premier de la tableau. Pour affiner la recherche, il faut la faire porter
sur deux critères, par exemple le nom et le prénom. Pour cela, une
méthode consiste à insérer une colonne à gauche du nom dans laquelle
seront juxtaposés les nom et prénom. Pour retrouver les informations, il
faudra saisir le nom et le prénom en B4 et B5 . Pour obtenir l’adresse en
B6 , il faudra saisir :
=RECHERCHEV(B4&B5;Données!A2:H31;4;FAUX)
La plage de recherche inclut une colonne de plus (la colonne insérée à
gauche, sur laquelle porte la recherche). Il faut donc modifier le troi-
sième paramètre (l’adresse se trouve désormais en colonne 4, et non
en 3).
Éviter l’apparition de messages d’erreur
lors d’une recherche
Le cas que nous venons de traiter n’est pas parfait, puisqu’en cas
d’erreur de frappe dans le nom du contact, la fiche renverra le
message d’erreur #N/A .
Search JabSto ::




Custom Search