Microsoft Office Tutorials and References
In Depth Information
Figure 6.16 : Les conséquences d’une erreur de frappe
Cela n’est pas gênant et ne remet pas en cause la pertinence de
l’application. Toutefois, si vous concevez une application pour un
autre utilisateur, il pourra être déstabilisé par ce message intem-
pestif. Pour remédier à ce petit défaut, interceptez le message
d’erreur avant qu’il ne s’affiche et remplacez-le par un message
plus explicite. Pour cela, utilisez la fonction ESTNA , qui renvoie la
valeur VRAI si son argument est égal à #N/A et FAUX sinon.
En B5 , saisissez :
=SI(ESTNA(RECHERCHEV(B4;Données!A2:G31;2;FAUX));"Inconnu";
RECHERCHEV(B4;Données!A2:G31;2;FAUX))
En procédant de la même manière, vous pouvez ainsi prévenir
l’apparition des messages d’erreur pour chacune des informa-
tions de la fiche.
Figure 6.17 : La fiche de contact « sécurisée »
Utiliser d’autres techniques de recherche
La fonction RECHERCHEV est très pratique pour rechercher des don-
nées dans une plage de cellules. Pourtant, elle ne peut être utilisée
dans toutes les situations. En effet, le critère de recherche doit
impérativement se trouver dans la première colonne de la plage
Search JabSto ::




Custom Search