Microsoft Office Tutorials and References
In Depth Information
Figure 6.19 : L’annuaire inversé
Exploiter des données sous forme
d’intervalles
Jusqu’à présent, vous avez recherché des valeurs exactes. Dans
certaines situations, il peut être nécessaire d’effectuer des recher-
ches « approchées ». L’exemple suivant va vous permettre de
mieux comprendre l’utilité de telles recherches.
Supposons que vous disposiez d’un tarif dégressif en fonction des
quantités. Le tarif est présenté sous forme de paliers.
Figure 6.20 : Tarif dégressif
Pour rechercher le tarif associé à une quantité spécifiée en B3 ,
utilisez la fonction RECHERCHEV en B4 :
=RECHERCHEV(B3;D4:F9;3)
Le dernier paramètre étant omis, il est considéré comme étant
égal à VRAI . Cela signifie que la fonction s’arrête à la valeur
immédiatement inférieure à la valeur cherchée. Il est donc néces-
saire que la colonne de recherche soit triée dans l’ordre croissant.
Ainsi, la fonction trouvera la ligne correspondant à la borne infé-
rieure du palier de quantité correspondant à la quantité saisie en
B3 . Il suffit alors de renvoyer le tarif associé qui se trouve dans la
troisième colonne.
Search JabSto ::




Custom Search