Microsoft Office Tutorials and References
In Depth Information
moyenne mobile à 10 jours pour le jour J, établissez la moyenne
des valeurs de J - 9, J - 8, J - 7… J - 1, J. Pour calculer la moyenne
mobile à 10 jours pour le jour J + 1, établissez la moyenne des
valeurs de J - 8, J - 7… J, J + 1. Et ainsi de suite, pour les jours
suivants.
Pour mettre en œuvre ce principe dans Excel, utilisez la fonction
DECALER , qui permet d’obtenir une plage de cellules décalée d’un
nombre spécifié de lignes et de colonnes par rapport à une plage
initiale.
Dans notre exemple, les valeurs se trouvent dans la colonne B
partir de B7 .En C4 se trouve un paramètre qui est en fait le
nombre de périodes de la moyenne mobile (ici 10). La moyenne
mobile doit être calculée en colonne C , à partir de C7 .
Figure 6.24 : Le tableau de valeurs
Avant de tenter le calcul de la moyenne mobile, vérifiez qu’il y
aura assez de valeurs pour mener à bien le calcul sur le nombre
choisi de périodes (en C4 ). Une fois la vérification effectuée, réa-
lisez le calcul de la moyenne sur une plage de 10 cellules à comp-
ter de la cellule située sur la même ligne et dans la colonne B .
Ensuite, calculez la moyenne sur la plage bornée par la cellule
située sur la même ligne dans la colonne B et la cellule située
9 cellules plus haut (pour traiter 10 valeurs). Voici la formule à
saisir en C7 :
=SI(A7 > =$C$4;MOYENNE(B7:DECALER(B7;-$C$4+1;0));"")
Le cœur de la formule est bien entendu le calcul de la moyenne :
Search JabSto ::




Custom Search