Microsoft Office Tutorials and References
In Depth Information
Utiliser la fonction SOMMEPROD de façon détournée
Dans notre exemple, les données se trouvent sur la feuille Données
(colonne A = magasin, colonne B = mois, colonne C = produit,
colonne D = montant des ventes). Sur une feuille baptisée Synthèse ,
vous allez exploiter ces informations. Pour cela, vous utiliserez de
façon détournée la fonction SOMMEPROD . Cette fonction effectue le
produit ligne à ligne des valeurs des plages fournies en argument,
puis calcule la somme de l’ensemble des produits. Vous exploite-
rez le fait que la valeur logique VRAI correspond à la valeur numé-
rique 1, et la valeur logique FAUX à la valeur numérique 0, pour
intégrer des plages qui seront en fait des tests sur différents
critères.
Ainsi, si le mois choisi se trouve en B3 , le magasin en B4 et l’article
en B5 :
j Vous obtiendrez les ventes du magasin pour le mois avec la
formule :
=SOMMEPROD((Données!A2:A81=$B$4)*(Données!B2:B81=$B$3)*
(Données!D2:D81))
j Vous obtiendrez les ventes de l’article dans le magasin avec la
formule :
=SOMMEPROD((Données!A2:A81=$B$4)*(Données!C2:C81=$B$5)*
(Données!D2:D81))
j Vous obtiendrez les ventes de l’article sur le mois avec la
formule :
=SOMMEPROD((Données!B2:B81=$B$3)*(Données!C2:C81=$B$5)*
(Données!D2:D81))
Figure 6.27 : Synthèses rapides
En fait, lorsque vous écrivez Données!A2:A81=$B$4 , le résultat est
une plage qui contient 1 lorsque la valeur de la colonne A est
égale au contenu de B4 , et 0 sinon. De même avec
Données!B2:B81=$B$3 . Ainsi, lorsque ces plages sont multipliées
Search JabSto ::




Custom Search