Microsoft Office Tutorials and References
In Depth Information
Compter le nombre d’occurrences d’un
caractère ou d’un mot dans un texte
Pour compter combien de fois apparaît un caractère ou un mot
dans un texte, vous disposez d’une méthode classique qui
consiste à faire la différence entre le nombre de caractères du
texte initial et le nombre de caractère du texte obtenu en suppri-
mant toutes les occurrences du mot ou du caractère choisi. Si la
recherche porte sur un caractère unique, le nombre obtenu est le
nombre de fois où le caractère apparaît dans le texte. Si la recher-
che porte sur un mot, il faut diviser le nombre obtenu par le
nombre de caractères du mot choisi. Si le texte initial se trouve en
A1 et le caractère ou le mot dont il faut compter les occurrences se
trouve en B1 , la formule suivante effectue le calcul :
=(NBCAR(A1)-NBCAR(SUBSTITUE(A1;A2;"")))/NBCAR(A2)
Extraire le premier mot d’un texte
Supposons que vous disposiez d’un texte dans la cellule A1 .
Comme dans tous les textes, les mots sont séparés par des espa-
ces. C’est ce que vous allez exploiter pour identifier, puis isoler le
premier mot. Il s’agit en fait de localiser le premier espace dans le
texte. Le premier mot est situé à gauche de ce premier espace. La
formule suivante met en œuvre ce mécanisme :
=GAUCHE(A1;TROUVE(" ";A1)-1)
Si le texte contient des espaces parasites (au début du texte, par
exemple), vous pouvez inclure la fonction SUPPRESPACE dans la
formule précédente, afin de « nettoyer » le texte avant de tra-
vailler dessus :
=GAUCHE(SUPPRESPACE(A1);TROUVE(" ";SUPPRESPACE(A1))-1)
Ces formules renvoient une erreur si le texte ne contient pas un
seul espace. Il est possible de contourner de souci en utilisant la
fonction SI :
=SI(ESTERR(TROUVE(" ";A1));A1;GAUCHE(A1;TROUVE(" ";A1)-1))
Extraire le dernier mot d’un texte
De la même façon que précédemment, il est possible d’isoler le
dernier mot d’un texte. Dans ce cas, il s’agit d’identifier le dernier
espace du texte et d’isoler tous les caractères se trouvant à sa
droite. Pour identifier le dernier espace, il faut le différencier des
Search JabSto ::




Custom Search