Microsoft Office Tutorials and References
In Depth Information
Repérer une date anniversaire
Si vous utilisez Excel pour gérer votre Carnet d’adresses, vous
pouvez créer une fonction « Anniversaire », qui affichera un mes-
sage en face du nom de votre ami le jour de son anniversaire. Pour
cela, supposons que sa date de naissance se trouve en D10 :
=SI(ET(MOIS(AUJOURDHUI())=MOIS(D10);JOUR(AUJOURDHUI())=
JOUR(D10));"Bon anniversaire";"")
Il suffit de tester que le jour et le mois courants sont identiques à
la date de naissance.
Vous pouvez améliorer cette formule afin d’être prévenu de l’évé-
nement dix jours avant la date anniversaire, et d’afficher ce rappel
jusqu’au jour en question :
=SI(ABS(AUJOURDHUI()-DATE(ANNEE(AUJOURDHUI());MOIS(D10);
JOUR(D10))) < =10;"Période d’anniversaire";"")
Il faut vérifier que la valeur absolue de la différence entre la date
du jour et la date correspondant à l’anniversaire pour l’année en
cours (soit DATE(ANNEE(AUJOURDHUI());MOIS(D10);JOUR(D10)) ) est
inférieure ou égale à 10.
Tester si une année est bissextile
Pour tester si le mois de février compte 29 jours ou non, en
supposant que l’année soit saisie en A1 , voici la formule à utiliser :
=SI(MOIS(DATE(A1;2;29))=2;"Année bissextile";"")
Vous profitez ici de la « souplesse » d’Excel. En effet, si le 29 fé-
vrier de l’année choisie existe, DATE(A1;2;29) renvoie bien
29/02/aaaa . En revanche, si cette date n’existe pas, DATE(A1;2;29)
renvoie 01/03/aaaa . Testez alors le mois de cette date et vérifiez
qu’il est bien égal à 2.
8.4.
Faire des calculs sur les heures
Nous allons à présent détailler deux traitements relatifs aux heu-
res.
Search JabSto ::




Custom Search