Microsoft Office Tutorials and References
In Depth Information
{=MOYENNE(GRANDE.VALEUR(A1:A10;{1;2;3}))}
Ne saisissez pas les accolades entourant la formule. Elles appa-
raissent automatiquement après la validation par [Ctrl] + [Maj] + [Ä] .
Figure 10.10 : Calcul matriciel de la moyenne des trois plus grandes valeurs
Cette formule fonctionne en fait « en deux temps ». Tout d’abord,
elle procède à la création d’un tableau de 1 colonne et de 3 lignes :
j 1 ère ligne : GRANDE.VALEUR(A1:A10;1) ;
j 2 ème ligne : GRANDE.VALEUR(A1:A10;2) ;
j 3 ème ligne : GRANDE.VALEUR(A1:A10;3) .
Ensuite, la fonction MOYENNE calcule la moyenne de ce tableau
intermédiaire, renvoyant ainsi le résultat désiré.
Compter des cellules contenant du texte
Pour compter le nombre de cellules contenant du texte dans une
plage de cellules (ici B1:B10 ), utilisez la formule suivante :
{=SOMME(ESTTEXTE(B1:B10)*1)}
Un tableau intermédiaire de 10 lignes et 1 colonne est créé. Il
contient 1 si la cellule correspondante dans B1:B10 contient du
texte, et 0 sinon. Ainsi, la fonction SOMME totalise bien le nombre de
cellules contenant du texte. La fonction ESTTEXTE renvoie un résul-
tat booléen, soit VRAI ou FAUX . Les propriétés suivantes sont alors
utilisées :
j VRAI*1=1 ;
j FAUX*1=0 .
Search JabSto ::




Custom Search