Microsoft Office Tutorials and References
In Depth Information
Compter les doublons dans une liste
Pour compter le nombre de données d’une plage ( B1:B10 ) égale-
ment présentes dans une autre plage ( A1:A10 ), voici la formule à
utiliser :
{=SOMME(NB.SI(A1:A10;B1:B10))}
Figure 10.11 : Nombres de données de B également présentes dans A
Faire des calculs conditionnels
Il est possible, grâce aux formules matricielles, de faire des calculs
conditionnels. Supposons que vous disposiez d’un tableau de
données issues d’un système de gestion commerciale, qui se
compose de quatre colonnes : ville (plage A2:A81 ), mois (plage
B2:B81 ), produit (plage C2:C81 ) et ventes (plage D2:D81 ).
Pour connaître le montant des ventes à Lyon en février, recourez à
la formule matricielle suivante :
{=SOMME((A2:A81="Lyon")*(B2:B81="Février")*D2:D81)}
Figure 10.12 : Montant des ventes en fonction de deux critères
Vous utilisez à nouveau les propriétés des valeurs booléennes
( VRAI et FAUX ) lorsqu’elles sont multipliées par des valeurs numé-
riques. En multipliant les valeurs, vous obtenez une combinaison
logique ET .
Search JabSto ::




Custom Search