Microsoft Office Tutorials and References
In Depth Information
{=SOMME((JOURSEM(DATE(A2;A1;LIGNE(INDIRECT("1:"&JOUR(DATE
(A2;A1+1;0))))))=2)*1)}
Cette formule est un peu complexe. Nous allons donc la détailler.
Il s’agit en fait de tester si le jour de la semaine (fonction JOURSEM )
de chacun des jours du mois est égal à 2, c’est-à-dire au lundi.
Pour faire « défiler » les jours du mois (en utilisant la fonction
DATE ), vous utilisez en fait le principe vu précédemment, qui per-
met d’obtenir une suite de nombres entiers :
LIGNE(INDIRECT("1:"&JOUR(DATE(A2;A1+1;0))))
Toute la difficulté réside ici dans la détermination du dernier jour
du mois, soit :
JOUR(DATE(A2;A1+1;0))
Pour obtenir le dernier jour du mois, il faut utiliser une astuce : il
s’agit d’exploiter le « 0 e » jour du mois suivant. La fonction JOUR
donne ensuite son numéro.
Il est possible de compter les autres jours de la semaine en
remplaçant 2 par 3 pour le mardi, par 4 pour le mercredi, 5 pour le
jeudi, 6 pour le vendredi, 7 pour le samedi et 1 pour le dimanche.
Transposer une matrice
Transposer une matrice consiste à obtenir une matrice dont les
lignes sont composées des éléments des colonnes de la matrice
initiale. Il y a une symétrie par rapport à la diagonale de la matrice
initiale. Pour obtenir la transposée de la matrice A1:D5 , qui
compte 5 lignes et 4 colonnes, sélectionnez une plage de 4 lignes
et 5 colonnes (par exemple A9:E12 ) et saisissez :
{=TRANSPOSE(A1:D5)}
Figure 10.14 :
Transposition de matrice
Search JabSto ::




Custom Search