Microsoft Office Tutorials and References
In Depth Information
Inclure une formule dans la condition
Afin d’étendre les possibilités des formules conditionnelles, il
est possible d’inclure des formules et des fonctions dans les
critères de test. Supposons que vous souhaitiez mettre en exer-
gue, parmi une liste de produits, ceux dont le chiffre d’affaires
est supérieur à la moyenne. Il faut inclure dans le test la
moyenne des chiffres d’affaires, ce qui est possible à l’aide de la
fonction MOYENNE .
Si les valeurs à tester se trouvent dans la plage B4:B15 , la formule
à saisir en C4 est la suivante :
=SI(B4 > MOYENNE($B$4:$B$15);"Supérieur à la moyenne";"")
Ensuite, étendez-la, à l’aide de la poignée de recopie, jusqu’à la fin
du tableau.
Figure 4.7 : Utilisation d’une fonction dans un critère
Notez l’utilisation de références absolues comme arguments de la
fonction MOYENNE . En effet, il est nécessaire de faire référence à la
même plage, quelle que soit la ligne du tableau.
Pour plus d’informations sur les références absolues,
reportez-vous au chapitre Élaborer des formules simples .
Compter le nombre de valeurs différentes
dans une plage de cellules triées
Si vous disposez d’une liste de valeurs (réponses à un question-
naire, notes à un examen…), il est souvent intéressant de connaî-
Search JabSto ::




Custom Search