Microsoft Office Tutorials and References
In Depth Information
Il s’agit en fait d’imbriquer des fonctions SI , de façon à mettre en
place chacun des « embranchements » de l’arbre de décisions.
Les arguments de la première fonction SI sont eux-mêmes des
fonctions SI , dont les arguments sont à leur tour des fonctions SI .
Nous avons ici affaire à une imbrication à trois niveaux, qui se
matérialise de la façon suivante avec la syntaxe Excel :
=SI(condition1;SI(condition2;SI(condition3;Action1;Action2);
SI(condition4;Action3;Action4));SI(condition5;SI(condition6;
Action5;Action6);SI(condition7;Action7;Action8)))
Il est possible d’imbriquer jusqu’à 64 niveaux de test SI . Autant
dire que certaines formules peuvent être illisibles !
Rendre les formules plus lisibles
Pour rendre vos formules complexes plus lisibles, il est possible
d’insérer des sauts de ligne lors de la saisie, à l’aide de la combinaison
de touches [Alt] + [Ä] . La formule précédente peut ainsi s’écrire :
=SI(condition1;
SI(condition2;
SI(condition3;Action1;Action2);SI(condition4;Action3;Action4));
SI(condition5;
SI(condition6;Action5;Action6);SI(condition7;Action7;Action8)))
Limiter la taille des formules
Dans certains cas, les alternatives proposées dans un test SI
diffèrent très légèrement (la valeur d’un coefficient par exemple).
Afin d’éviter d’alourdir la saisie des formules et de contribuer à
leur meilleure lisibilité, il est préférable de n’inclure dans le test
que la partie conditionnelle de la formule.
Prenons un exemple. Supposons qu’une formule de calcul soit
conditionnée par le contenu de la cellule A23 . Si le contenu de A23
est inférieur ou égal à 100 , la formule est B23*(C23 D23)*0,5 . Si-
non, la formule est B23*(C23 D23)*0.75 .
Une première approche (qui donne un résultat correct) est :
=SI(A23 < =100 ;B23*(C23-D23)*0.5;B23*(C23-D23)*0.75)
Voici une autre possibilité, plus concise :
=B23*(C23-D23)*SI(A23 < =100;0.5;0.75)
Search JabSto ::




Custom Search