Microsoft Office Tutorials and References
In Depth Information
4.2.4 Personal
nummer berechnet, so kann die Formel bis zum Monatsende nach
rechts kopiert werden. Die Zeile 5 kopiert das Datum und zeigt über
ein anderes Zahlenformat den Wochentag an.
B6: =DATUM(Jahr;$B$3;SPALTE()-1), Zahlenformat TT
B5: =B6, Zahlenformat TTT
Um die unterschiedliche Anzahl Tage pro Monat und den 29. Feb-
ruar an Schaltjahren zu berücksichtigen, wird dieser über eine For-
mel berechnet, die den Folgetag des 28. Februar abprüft:
AD6: =WENN(TAG($AC$6+1)=1;0;$AC$6+1)
In Spalte A werden die Namen der Arbeitnehmer eingetragen und um
die Eingabe und Berechnung der Arbeitsstunden zu erleichtern,
bekommt der gesamte Tabellenbereich ein Bedingungsformat, das
Samstage und Sonntage mit einem Hintergrundmuster versieht.
Damit auch Feiertage und freie Tage berücksichtigt werden, steht das
Tabellenblatt Feiertage mit der Feiertagsberechnung pro Bundesland
zur Verfügung (siehe Kapitel 2.1.8). Der Bereich mit den Datums-
werten der Feiertage trägt den Bereichsnamen FLISTE.
Diese Regeln formatieren die arbeitsfreien Tage für die erste Zelle
(B5):
Regel 1: =UND(WOCHENTAG(B$5)=7;B$5<>0)
Regel 2: =UND(WOCHENTAG(B$5)=1;B$5<>0)
Regel 3: =UND(NICHT(ISTNV(VERGLEICH(B$5;FTAGE;0)));B$5<>0)
Lohnabrechnung mit Matrixformeln
Für die Berechnung der Arbeitstunden pro Monat und Arbeitnehmer
reicht eine einfache Summe nicht aus. Die Arbeitsstunden müssen mit
der Datumsreihe verglichen werden, damit die Abrechung zwischen
Wochenendstunden und Wochentagsstunden unterscheiden kann. Im
Bereich ab der Zelle AH7 befindet sich die Berechnung. Ein Klick auf
das Ebenensymbol der Gliederung öffnet den Bereich.
Die erste Formel vergleicht die Arbeitsstunden des ersten Arbeitneh-
mers mit den Wochentagen der Datumsreihe B6:AF6. Die Kombina-
tion aus SUMME() und WENN() summiert nur Stunden auf, die der
Bedingung entsprechen. Damit die Formel die Matrix Element für
Element vergleichen kann, muss sie mit (Strg) + (ª) + (¢) abgeschickt
werden.
Search JabSto ::




Custom Search