Microsoft Office Tutorials and References
In Depth Information
4.2.4 Personal
rechnet. Neben den persönlichen Daten des Mitarbeiters (Name,
Abteilung, Kostenstelle, Gebiet) zeigt der Kopfbereich die beiden
Datumswerte Reiseanfang und Reiseende an. Diese Datumswerte
werden per Formel aus dem Minimal- und Maximalwert der
Datumsspalte berechnet:
Vom:=WENN(MIN($B$11:$B$23)=0;"";MIN($B$11:$B$23))
Bis:=WENN(MAX($B$11:$B$23)=0;"";MAX($B$11:$B$23))
Spalte B ist für die Eingabe der Datumswerte reserviert. Geben Sie
die Datumswerte ein oder benutzen Sie den VBA-Kalender, der mit
Klick auf das Kalendersymbol am linken Rand startet. Das gewählte
Datum wird in die Datumszelle in Spalte B eingetragen.
Abbildung 4.181: Reisekostenformular
Die Reisezeiten werden aus den Kombinationsfeldern in Spalte D
geholt, sie bieten die Zeit für je einen Tag in 15-Minuten-Abständen
an. Die Berechnung der Stundendifferenz zwischen Reisebeginn und
Reiseende eines Tages übernimmt die Spalte F.
F11: =WENN(UND(B11<>"";D12>D11);D12-D11;0)
In Spalte E steht ein weiteres Formularelement (Kombinationsfeld)
bereit. Es enthält die Liste der Länder, für die Tagegeldpauschalen in
der Datentabelle hinterlegt sind. Wählen Sie hier den ersten Eintrag
Inland , wenn die Reise in Deutschland stattfand, oder suchen Sie das
entsprechende Reiseland.
Search JabSto ::




Custom Search