Microsoft Office Tutorials and References
In Depth Information
2.4.5 Fehlerbehandlung mit ISTFEHLER() und WENNFEHLER()
Abbildung 2.24: Bestellungen mit Lieferant und Gesamtwert
2.4.5
Fehlerbehandlung mit ISTFEHLER() und WENNFEHLER()
Mit Informationsfunktionen wie ISTNV(), ISTFEHLER() oder IST-
ZAHL() sichern Sie Formeln ab und verhindern Fehlerwerte in den
Tabellenblättern. Fehlerwerte sind natürlich erwünscht, wenn sie auf
falsche Kalkulationen oder nicht passende Datentypen hinweisen
(z. B. Text statt Zahl), in der Praxis stören sie aber, wenn Tabellen
bereits mit Formeln versehen sind und noch auf Daten vom Anwen-
der warten. In Kombination mit WENN() lässt sich beispielsweise
ISTFEHLER() einsetzen, um den Zellinhalt so lange zu verbergen, bis
alle Argumente besetzt sind:
A1: 100
A2: 0
A3: =WENN(ISTFEHLER(A1/A2);"";A1/A2)
Ab der Version 2007 bietet Excel eine neue Funktion WENNFEH-
LER() an, die das Ganze etwas vereinfacht. Geben Sie einfach als ers-
tes Argument den Rechenausdruck an und als zweites die Formel
oder den Zellinhalt, der im Fehlerfall anzuzeigen ist:
=WENNFEHLER(A1/A2;"")
Search JabSto ::




Custom Search