Microsoft Office Tutorials and References
In Depth Information
2.5.3 Kalenderwoche berechnen
Abbildung 2.27: Die Feiertage-Tabelle enthält eine makrofreie Feiertagsberechnung
Alle Optionsfelder erhalten über Eigenschaft (aus dem Kontextmenü
der rechten Maustaste) eine Verknüpfung auf die Zelle B1. In B1
steht nach Auswahl eines Bundeslands der Index auf das Bundesland
(z. B. 5 für Berlin, 18 für Sachsen).
In der ausgeblendeten Spalte D steht ein Bitmuster, das die Abfolge
der Feiertage des jeweiligen Bundeslandes bestimmt. In W1 steht eine
Formel, die das Bitmuster des (in B1) eingestellten Bundeslands
berechnet:
=BEREICH.VERSCHIEBEN($W$2;B1-1;0)
Die festen, nicht von Ostern abhängigen Feiertage werden mit der
Funktion DATUM in Abhängigkeit von der Jahreszahl in Zelle A1
berechnet, hier zum Beispiel das Neujahrsfest am 1. Januar:
=DATUM(JAHR;1;1)
Ob der Feiertag für das gewählte Bundesland gültig ist, entscheidet
die Position im Bitmuster. Mit der Funktion TEIL() lässt sich die Zif-
fer aus der Zeichenkette herausrechnen und bei nicht einheitlichen
Feiertagen wird das Ergebnis, 0 oder 1, mit dem Datum multipliziert,
damit der Feiertag korrekt angezeigt wird.
=DATUM(JAHR;MONAT;TAG)*WERT(TEIL($D$1;1;1))
Die beweglichen Feiertage orientieren sich am Osterdatum und wer-
den über eine Verknüpfung berechnet. Damit auch die Feiertags-
bezeichnung nur bei passendem Wert im Bitmuster angezeigt wird,
sichert eine WENN-Funktion den Text ab:
F9: =(F5+59)*WERT(TEIL($D$1;ZEILE();1))
G9: =WENN(F9;"Fronleichnam";"")
Search JabSto ::




Custom Search