Microsoft Office Tutorials and References
In Depth Information
2.5.3 Kalenderwoche berechnen
Für inoffizielle Feiertage wie Rosenmontag, Faschingsdienstag oder
Hl. Abend steht ein Ankreuzkästchen zur Verfügung, das mit einer
Zelle in Spalte E verknüpft ist. Mit einer WENN-Funktion lässt sich
auch dieser Tag dann als Feiertag ausweisen:
=WENN(E18;F5-49;0)
Excel-Praxis: Ewiger Kalender mit Feiertagen
Für Ihre Terminplanung brauchen Sie einen Kalender, der automa-
tisch nach Eingabe der Jahreszahl die Monatsdatumswerte berech-
net. Die Kalendervorlage verwendet dazu die Funktion DATUM()
mit der Jahreszahl aus Zelle A1, dem Monat aus dem Datum in der
Kopfzeile und der eigenen Zeilennummer für den Kalendertag.
A3: =DATUM($A$1;MONAT(A$2);ZEILE()-2)
Der Sonderfall »Schaltjahre« ist natürlich auch berücksichtigt, die
Formel prüft, ob der Folgetag des 28. Februar der 29. oder der 1. März
ist, und trägt das Datum entsprechend ein:
D31: =WENN(TAG(D30+1)=29;D30+1;"")
Bedingungsformat für die Wochenenden
Mit zwei Regeln wird das Bedingungsformat für die Datumswerte
bestimmt, das alle Wochenendtage (Samstage, Sonntage) einfärbt.
Regel 1: =UND(A3<>"";WOCHENTAG(A3)=7)
Regel 2: =UND(A3<>"";WOCHENTAG(A3)=1)
Abbildung 2.28: Die Datumswerte berechnet der Kalender aus Jahreszahl,
Monat und Zeilennummer
Feiertage
Für die Feiertage in der zweiten Spalte wurde die Feiertagsberech-
nung mit Bundeslandauswahl in die Arbeitsmappe kopiert (siehe
Search JabSto ::




Custom Search