Microsoft Office Tutorials and References
In Depth Information
2.5.3 Kalenderwoche berechnen
Kapitel 2.1.8) Der Bereich FLISTE enthält die Feiertagsdatumswerte,
eine Formel mit der Funktion SVERWEIS() sorgt dafür, dass die Fei-
ertage in den Kalender übertragen werden. ISTNV() prüft ab, ob das
Datum in der Liste vorkommt.
B3: =WENN(ISTNV(SVERWEIS(A3;FLISTE;2;FALSCH));"";SVERWEIS(A3;FLISTE;2;FALSCH))
Etwas aufwändiger, aber makrofrei ist die Kalenderwochenberech-
nung in der dritten Spalte. Die WENN()-Funktion prüft noch ab, ob
das Datum auf einen Montag fällt:
C3: =WENN(WOCHENTAG(A3)=2;KÜRZEN((A3-WOCHENTAG(A3;2)-DATUM(JAHR(A3+4-
WOCHENTAG(A3;2));1;-10))/7);"")
Excel-Praxis: VBA-Makro Termine aus Outlook
Der Kommunikation-Manager und E-Mail-Client Outlook bietet
zwar auch die Möglichkeit, Feiertage zu berechnen, dazu wird eine
Textdatei mit der Bezeichnung Outlook.txt bzw. Outlook.hol (2007)
eingelesen, detailliert mit Bundeslandauswahl lässt sich die Feiertags-
verwaltung aber nicht durchführen. Nutzen Sie diese VBA-Makro-
Vorlage, um alle Outlook-Termine in den ewigen Kalender zu über-
tragen.
VBA-Makro Outlook-Termine.xls
Basisdaten
In diesem Tabellenblatt finden Sie die Feiertagsberechnung nach
Bundesland. Stellen Sie Ihr Bundesland ein. Die Jahreszahl wird das
Makro abfragen.
Tragen Sie in die Liste ab Spalte K die Kategorien ein, die Sie in Out-
look angelegt hatten und stellen Sie in Spalte L die Farbe ein, die Sie
im Kalender für die jeweilige Kategorie nutzen wollen.
Kalendervorlage
Die Kalendervorlage enthält den ewigen Kalender mit Feiertagen und
KW-Berechnung.
Makro für Outlook-Termine
Starten Sie das Makro zur Übertragung der Outlook-Termine mit
Klick auf das Symbol im Tabellenblatt START oder über die benut-
zerdefinierte Symbolleiste. In Excel 2007 finden Sie diese in der
Gruppe Add-In s.
CD .......
Search JabSto ::




Custom Search