Microsoft Office Tutorials and References
In Depth Information
2.5.5 Die Excel-Zeitrechnung
Abbildung 2.31: Berechnung von Zeitdifferenzen
Negativzeiten berechnen
Kritisch wird das Ganze bei Negativzeiten. Liegt das Arbeitsende vor
dem Arbeitsbeginn (z. B. bei Schichtarbeit, Beginn 20:00 Uhr, Ende
4:00 Uhr), zeigt die Zelle mit der einfachen Formel »=Ende- Beginn«
eine durchlaufende Kette von #-Zeichen an. Der Grund ist einleuch-
tend, wenn das Prinzip der Zeitberechnung bekannt ist: Das Ergebnis
würde im Bereich vor dem ersten Kalendertag landen und für diesen
lässt Excel keine Datums- oder Zeitberechnung zu. Eine (schlechte)
Alternative ist die Umstellung auf das 1904-Datumsformat, das aus
Kompatibilitätsgründen zum Apple Macintosh-System enthalten ist:
Unter Extras/Optionen wird auf der Registerkarte Berechnen die
Option 1904-Datumswerte angekreuzt. Damit ist der Kalender um
4 Jahre nach vorne versetzt, was für einfache Zeitberechnungen nütz-
lich sein mag, die Tabellen aber gehörig durcheinanderbringt, sobald
parallel mit Datums- und Zeitwerten gearbeitet wird. Die bessere
Methode, um Negativzeiten zu berechnen, ist diese: Konstruieren Sie
die Formel mithilfe der WENN-Funktion so, dass sie auch Zeit-
sprünge zwischen zwei Datumswerten richtig berechnet:
D2: =WENN(C2>B2;C2-B2;1-B2+C2)
Mit einer WENN-Formel lösen Sie auch das Problem der Sollzeiten-
berechnung, die zwar einfach als Differenz zwischen Arbeitszeit und
Sollzeit errechnet wird, bei Zeitangaben, die unter dem Soll liegen,
aber automatisch negativ und damit nicht darstellbar wird.
Zeitwerte summieren
Die Addition von Zeitwerten ist mit der richtigen Formatierung kein
Problem. Wenn Sie wie oben beschrieben die Werte per Multiplika-
tion mit 24 in Dezimalzahlen umgewandelt haben, genügt eine einfa-
che Summe mit der gleichnamigen Funktion:
=SUMME(bereich)
Bei reinen Zeitwerten tritt ein Problem auf: Das Ergebnis wird nie
mehr als 24 Stunden betragen. Im obigen Beispiel würde die Summe
 
Search JabSto ::




Custom Search