Microsoft Office Tutorials and References
In Depth Information
Die Funktion führt also eine Wahrheitsprüfung durch und liefert als Ergebnis einen
Dann_Wert oder einen Sonst_Wert . Warum die Betonung auf eine liegt, werden Sie
gleich sehen.
Die Wahrheitsprüfung kann nun direkt über konstante Werte erfolgen:
=WENN(5>3;"grösser";"kleiner")
=WENN(WAHR;"grösser";"kleiner") = "grösser"
oder indirekt mit Bezug auf einen Tabellenbereich:
A1:=2
=WENN(A1>3;"grösser";"kleiner") = "kleiner"
Nun nehmen wir an, es soll nicht nur eine Zahl überprüft werden, sondern die drei
Zahlen der Matrixkonstanten:
{2.4.5}
Benutzen wir die Matrixkonstante auf direktem Wege in der Formel, erhalten wir:
=WENN({2;4;5}>3;"grösser";"kleiner")
Das erste Argument der WENN-Funktion erwartet eine Wahrheitsprüfung. In dem
Moment, in dem wir ihr an der Stelle drei Wahrheitsprüfungen zumuten, machen wir
aus der „normalen“ Formel eine Array-Formel. Jeder der drei Werte wird mit der 3
verglichen, sodass wir erhalten:
=WENN({FALSCH;WAHR;WAHR};"grösser";"kleiner")
Als Ergebnis liefert die Funktion nicht nur einen Rückgabewert, sondern drei, nämlich:
{"kleiner";"grösser";"grösser"}
Sichtbar wird diese Ergebnismatrix dann, wenn Sie die Formel in eine Zelle schrei-
ben, markieren und mit (F9) auswerten.
Nun schlagen wir wieder den indirekten Weg ein. Die zu überprüfenden Werte werden
nicht konstant in die Formel übernommen, sondern stehen in einem Tabellenbereich
gemäß Abbildung 5.11.
Nun sehen wir mit Schrecken, dass Excel nicht in der Lage ist, diese Mehrfachprüfung
auszuführen. Nach dem Motto: „Ich möchte EINE Wahrheitsprüfung durchführen, aber
du bietest mir drei Zellen an, die geprüft werden sollen. Welche soll ich denn nehmen?“
Excel kapiert in dem Falle nicht, dass alle Zellen geprüft werden sollen.
Search JabSto ::




Custom Search