Microsoft Office Tutorials and References
In Depth Information
Mit der Formel
F2:=C2/1,1^$B2
wird die Zahlung in C2 abhängig von der Anzahl der Zinsperioden in B2 zu 10 %
aufgezinst (1,1 = 1 + 10 %). Die Formel wird bis G4 kopiert, um auch die übrigen
Endwerte zu erhalten. Schließlich erhalten Sie mit
G5: =SUMME(F2:G4)
die Summe aller Endwerte. Dank Matrixformeln ist das Hilfstableau von F1:G5 gar
nicht notwendig. Stattdessen können Sie mit
D7: {=SUMME(C2:D4*1,1^B2:B4)}
alle Teilberechnungen auf einmal ausführen, vorausgesetzt, Sie schließen die Formel-
eingabe mit (Strg) + (ª) + (¢) ab.
C2:D4*1,1^B2:B4 erzeugt eine Ergebnismatrix mit sechs Einzelberechnungen, die aber
nicht dargestellt, sondern an die Funktion SUMME weitergegeben werden. Diese
summiert die Elemente und liefert nur noch einen übrig gebliebenen Funktionswert,
sprich: die Summe.
Sie haben bereits gesehen, wie über mathematische Operation Matrizen manipuliert
werden können. Nach gleichem Muster kann ein mathematischer Operator auf einen
Bereich angewendet werden, wodurch eine neue Matrix entsteht. Wir zerlegen obige
Berechnung in ihre Einzelteile. Zuerst werden die drei Zinsfaktoren (1,1 ^ Perioden )
berechnet:
1,1^B2:B4 = 1,1^{3;2;1} = {1,331 ; 1,21 ; 1,1}
Nun werden die Zinsfaktoren mit den Zahlungen multipliziert:
C2:D4*{1,331;1,21;1,1}
= {100 . 200 ; 100 . 300 ; 100 . 400} * {1,331 ; 1,21 ; 1,1}
= {133,1 . 266,2 ; 121 . 363 ; 110 . 440}
= 1433,30
Hier haben wir den Fall dass zwei Matrizen mit unterschiedlichen Dimensionen mul-
tipliziert werden. Die linke Matrix der Zahlungen ist zweidimensional (Trennzeichen
Punkt und Semikolon), und die rechte Matrix der Zinsfaktoren ist ein eindimensiona-
les Zeilenarray (Trennzeichen Semikolon).
Search JabSto ::




Custom Search