Microsoft Office Tutorials and References
In Depth Information
Den Bereich, den die Funktion VERGLEICH hier in eine Matrix umwandelt, können
wir auch direkt (konstant) dort eintragen:
F3: =VERGLEICH(2005; {2007;2006;2007;2005;...;2006};0) = 4
Der dritte Anwendungsfall kommt zur Geltung, wenn sich das Suchkriterium aus
Spalte A und B zusammensetzt. Spalte A und Spalte B werden mit dem & -Operator
verkettet. Dadurch entsteht eine Matrix, die Excel nur mit der Tastenkombination
(Strg) + (ª) + (¢) akzeptiert:
F4:{=VERGLEICH(2005&"Dez";A3:A12&B3:B12;0)} = 8
Hier haben wir also eine Matrixformel kreiert, die im Gegensatz zur WENN-Funktion
nur einen Rückgabewert liefert (wie im Standard). Fazit:
Entsteht eine Matrix in einem Argument, das standardmäßig eine Matrix oder einen
Bereich erwartet, liefert die Funktion auch nur die standardmäßige Anzahl der Rück-
gabewerte.
Anders ist der Fall wieder gelagert, wenn die Matrix im ersten Argument entsteht.
=VERGLEICH({"Jun"."Okt"."Mrz"};B3:B12;0) = {1.3.6}
Aus einem Suchkriterium werden drei. Also wird aus einem Rückgabewert auch
deren drei. (Der Juni wird an 1. Stelle gefunden, der Oktober an 3. Stelle und der
März an 6. Stelle.)
Argument Bereich oder Bezug
Es gibt Funktionen wie ZÄHLENWENN, RANG oder TEILERGEBNIS, die verlangen als
Argument einen Bereich bzw. Bezug statt einer Matrix. An deren Verhalten wird
noch einmal sehr schön der Unterschied zwischen Matrix und Bereich klar.
Ein Bereich beinhaltet eine Matrix. Deshalb kann in einem Matrix-Argument sowohl
ein Bereich als auch eine Matrix angegeben werden. Andersherum gilt dies nicht.
Eine Matrix ist noch lange kein Bereich. Und deshalb verweigern die oben genannten
Funktionen die Übergabe von Matrizen:
=ZÄHLENWENN({2007;2006;2007;2005;2005};2005)
ist genauso wenig zulässig wie:
=ZÄHLENWENN(A3:A12&B3:B12;2005&"Dez")
Die Funktion ZÄHLENWENN verlangt also das reine, unmanipulierte „Medium“
Bereich . Funktionen, die als Argument Bezug statt Bereich verlangen, wie RANG oder
TEILERGEBNIS, verhalten sich gleichermaßen.
Search JabSto ::




Custom Search