Microsoft Office Tutorials and References
In Depth Information
Das Resultat ist natürlich nicht gleichbedeutend mit der Formel
ZÄHLENWENN(A:B; "x")
die nur eine Gesamtanzahl liefern würde.
Eine Matrix aus Bereichen lässt sich mit den Funktionen INDIREKT und BEREICH.VER-
SCHIEBEN erzeugen. Mit diesem Konstrukt lassen sich Fragestellungen beantworten
wie: In welcher Spalte kommen die meisten „x“ vor? Zudem lassen sich Berechnungen
für diskontinuierliche Bereiche verwirklichen (vgl. Excel – Das Zauberbuch ), die aber
an dieser Stelle zu weit führen würden.
Für Vergessliche
Die in den diversen Excel-Foren mittlerweile meistgenannte Funktion ist wohl SUM-
MENPRODUKT. Sie weist die Besonderheit auf, auf die Tastenkombination (Strg) +
(ª) + (¢) verzichten zu können.
Wird ein Bereich einer mathematischen Operation unterzogen, zum Beispiel
A1:A10*5
A1:A10 & B1:B10
entsteht eine Matrix, die Excel normalerweise nur mit der Tastenkombination berech-
nen kann. SUMMENPRODUKT versteht auch so, was zu tun ist (Abbildung 5.19):
Abbildung 5.19: Matrixformel ohne { }
=SUMMENPRODUKT((A1:A5&B1:B5)*1)
= 12 + 34 + 56 + 78 + 90 = 270
So besteht also nicht mehr die Gefahr, die Formeleingabe versehentlich ohne geschweifte
Klammern abzuschließen. Ansonsten hat die Formel keinen Vorteil gegenüber der her-
kömmlichen Matrixformel:
{=SUMME((A1:A5&B1:B5)*1)}
Search JabSto ::




Custom Search