Microsoft Office Tutorials and References
In Depth Information
5.4
Nichts als die Wahrheit
Die Zutaten zu diesem Bereich sind weder wahr noch falsch, sondern ausschließlich
WAHR und FALSCH. Wahrheitswerte sind unverzichtbar bei der Arbeit mit Array-
Formeln.
WAHR ist eine Bedingung immer dann, wenn sie nicht FALSCH ist.
=1=1 ergibt logischerweise WAHR.
=1=2 ergibt wiederum FALSCH.
Dank der Funktion NICHT lassen sich die Zustände auch umdrehen:
=NICHT(1=2) ergibt WAHR, denn =NICHT(FALSCH) ist eben nicht falsch und somit wahr.
=NICHT(1=1) ergibt FALSCH, denn =NICHT(WAHR) ist eben nicht wahr und somit falsch.
Auch wenn im reinen Excel die Funktion NICHT eher selten gebraucht wird, so ist die
doppelte Negierung in VBA gang und gäbe, da dort sehr oft mit den sogenannten
booleschen Variablen gearbeitet wird (Variablen, die nur die Wahrheitswerte WAHR
und FALSCH bzw. TRUE und FALSE zurückgeben können). Wenn die boolesche Variable
den Namen Bol trägt, dann ist folgende Abfrage nicht selten:
If Not Bol Then …
Ebenso wird im Zusammenhang mit Bereichsvariablen häufig ein If Not Bereich Is
Nothing Then … gebraucht. Also „Wenn nicht wahr/falsch, dann…” bzw. „Wenn nicht
Bereich ist nichts, dann …“.
Aber zurück zu Excel. Es wimmelt überall von Wahrheitswerten. Der bekannteste
Vertreter wird in der schlichten Funktion WENN gebraucht:
=WENN(A1=5; "Ja";"Leider keine 5")
A1=5 liefert entweder WAHR oder FALSCH – nicht mehr und nicht weniger.
Wenn man WAHR oder FALSCH mit irgendeiner mathematischen Operation (+, -, *, /)
verbindet, dann wird aus WAHR eine 1 und aus FALSCH eine 0. Die Abbildung 5.20
zeigt einige Rechenbeispiele:
Search JabSto ::




Custom Search